Whitys's Recent Activity

  1. Whitys liked Darksbane86's post in the thread Mamba Elite and Synapse 2.0.

    Yeah you gotta use synapse 3 for your mamba elite. Probably gotta build from scratch all your profiles. But if you have macros, you...

    Jan 13, 2019 at 5:14 AM
  2. Whitys liked Jenjar's post in the thread Mamba Elite and Synapse 2.0.

    The Mamba Elite will likely not be supported on Synapse 2, since Synapse 2 is a older software that is no longer getting support for the...

    Jan 12, 2019 at 3:44 AM
  3. Whitys posted a new thread.

    Mamba Elite and Synapse 2.0

    User of "BlackWidow Chroma Tournament Edition" and "Mamba Elite". Used Synapse 2 for a long period of time with my keyboard and...

    Forum: Mice and Surfaces

    Jan 11, 2019 at 4:42 AM
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >