Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

05/01 Razer Software Maintenance and Downtime

Discussion in 'Razer Synapse' started by Razer.WolfPack, Jan 4, 2018.

Thread Status:
Not open for further replies.
  1. hellsfan

    hellsfan New Member

    Ok, so yesterday everything was working fine and today when i started my PC Synapse won't display the surround options. My headset works fine on its own ( Kraken Pro v1). Don't think it is a technical issue in the headset, everything is connected. Please help :heart: Untitled.png
     
    Leehm likes this.
  2. DjRealm96

    DjRealm96 New Member

    Yep, having the same problem. Thought it was Razer messing up... Nope, should have guessed. Damn W10 causing problems, yet again! I remember my system getting an update just the other day(even though I told it to wait. F you W10!) and now my Surround Pro no longer works.

    It's things like this that slowly make me want to wipe 10 and go back to 7 as this isn't my first rodeo when it comes to dealing with Windows 10 messing up my computer. Grrrr

    So I hope Razer can get a fix out for microsofts blunder.
     
    Leehm likes this.
  3. AvlasenkoVitaliy

    AvlasenkoVitaliy New Member

    Mine Kraken Pro V2 was detected today by Synapse/Surround but I can't choose my headphones there as default device. Notebook dynamics set as default and other devices are greyed out and unavailable. So my Kraken don't work at all and sound goes through notebook... That's very bad.

    [​IMG]
     
  4. fistfullofbeer

    fistfullofbeer New Member

    Not sure if this is related or not but of the 3 Razer devices I have only the Razer Chroma Mat is getting detected by Synapse 3. BlackWidow Chroma V2 and Naga Trinity are not showing up. Last change I made yesterday was install the Synapse Module update.

    Is this some kind of known issue?
     
  5. Yosht

    Yosht New Member

    My Razer Surround Pro does not show in Razer Synapse and the surround doesn't seem to be working. It still worked yesterday. I have Razer Tiamat 2.2 headphones.
     
    Last edited: Jan 12, 2018
    Leehm likes this.
  6. Xereint

    Xereint Member

    Just waiting for all this razer surround issues to pass... Weird it worked yesterday and now we're back here
     
  7. -Rasinycon-

    -Rasinycon- New Member

    My Razer Synapse 3 beta has stopped working 1-2 days ago, i uninstalled it and trying it again but it won't install as it shows 0 B download next to install button.

    One product i have support Synapse 3 and it's Razer Firefly

    [​IMG]
    [​IMG]
     
    soloPerudome675 likes this.
  8. OpticalStrafe

    OpticalStrafe New Member

    when is the update???
     
  9. Noisyboy8888

    Noisyboy8888 New Member

    Downtime today, update might release after that probably.
     
  10. DjRealm96

    DjRealm96 New Member

    Ugh! The wait! It's killing me!!! I get it though. Need to cross the t's and dot the i's. Make sure the fix works on servers then us and so on. I just really miss my Razer Surround Pro is all... *sniffle* I miss you!!!!!!!!!!!!!!! ;)
     
    dhabak7777 likes this.
  11. Problem solved.Thanks
     
  12. Noisyboy8888

    Noisyboy8888 New Member

    Razer Surround is fixed? i already uninstalled just waiting it fixed.
     
  13. DjRealm96

    DjRealm96 New Member

    I haven't seen any update yet on my Synapse. Surround Pro still missing from list, so I'd still hold off, maybe on reinstalling?
    Or maybe that's what I need to do... Reinstall the whole thing to see if it will work.
     
  14. franctastic

    franctastic Member

    when is the update???
     
  15. nhrrrr

    nhrrrr New Member

    the appliance encountered a problem, please exit synapse and start again.

    wooow since 5jan ..... change the team best way to >>>> :mad_::rage:
     
  16. franctastic

    franctastic Member

    With the latest update of macOS to 10.13.4 beta (17E150g), Synapse has stopped working!
    Do not update!
    I uninstalled Synapse, reinstalled Synapse, and it’s NOT RUNNED!

    CRASH!

    https://imgur.com/a/gVz2w

    a disaster!

    salut!
     
  17. franctastic

    franctastic Member

    Hello, Razer developers.
    in case you guys haven't been paying attention, Apple has uploaded today (February 21) the latest update of macOS High Sierra to version 10.13.4

    Synapse still doesn't work...
    crash!

    for when the required update of Synapse?
    Synapse version 1.82 causes a lot of crashes, problems and errors
    I haven't used Synapse since two weeks!

    I'm indignant at Razer.

    salut!
     
  18. franctastic

    franctastic Member

  19. Dpakoc

    Dpakoc New Member

    Hello, my Razer Naga 2012, Razer Black Widow X Chroma just dissapear from Synapse while i was in the game. Only Kraken Pro 7.1 stay. More of that i can`t use usb ports 3.0 and 3.1 for keyabord and mouse. They work only on 2 usb ports. I believe you didnt broke my usb ports on my motherboard ASUS RIG MAXIMUS IX FORMULA.
     
  20. Dpakoc

    Dpakoc New Member

    Synapse just ignore evrything more than 24 hours. In this reason my mouse and keyabord have no drivers. Please do something with this synapse.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >