1st Gen Razer Phone Bluetooth Issues

Discussion in 'Razer Support' started by Spectre32787, Dec 30, 2019.

Thread Status:
Not open for further replies.
  1. Spectre32787

    Spectre32787 New Member

    Hi,

    I have a 1st Generation Razer Phone and have been very pleased with the product for a long time until just a few weeks ago I started having serious issues with the bluetooth.

    I have a pair of Soundcore Liberty Neo bluetooth earbuds that I have used with this phone for over a year. Suddenly, the audio stopped playing through the ear buds while listening to music through the phone on my way home form work. My Samsung Galaxy watch still works through it.

    I work in I.T. and know my way around electronics, especially phones and nothing I do remediates the issue.

    Steps Taken (All other bluetooth devices unpaired except for the ear buds):

    1: I turned Dolby on and off
    2: With Dolby on I turned the media audio on and off
    3: With Dolby off I turned the media audio on and off
    4: Turned Bluetooth On and Off
    5: Deleted the profiles and repeated steps 1-3
    6: Accessed Bluetooth system app and cleared cache
    7: Repeated steps 1-5
    8: Accessed Bluetooth system app and cleared storage
    9: Repeated steps 1-7
    10: Performed Hard Reset
    11: Repeated steps 1-8
    12: Performed Factory Reset
    13: repeated steps 1-8
    14: Performed Factor ROM Reset per the Razer Guidelines
    15: Bluetooth audio worked BRIEFLY (less than a day!!), and issues resumed


    I do not know where to go with this and as this is my only phone, I need Razer Support to explain to me why this feature has suddenly and totally failed to function.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You pretty much cleared out almost all possible troubleshooting that we recommend so there is a good chance that this is a Bluetooth module issue. I have a couple of questions for you though, do the wireless earphones work properly when paired with another device, and have you tried switching the Bluetooth Audio Codecs?
     
  3. Spectre32787

    Spectre32787 New Member

    Thank you for getting back with me.
    So given that is my primary means of communication both for work and personal, I cannot just send it in and be without a phone.

    For the earphones. Yes. I have paired them with another android phone, a MacBook Pro, and a Lenovo X1 Carbon laptop and all three send audio to the ear buds no problem.

    I'm not sure how to change codecs in the phone, unless you mean to try using a different Bluetooth accessory with the phone. If the Latter, my Samsung Galaxy Watch pairs just fine to it.

    Edit: Correction. My Watch is randomly cutting and and out of connection.
     
    Last edited by a moderator: Jan 3, 2020
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You can change codes in the Developer Options. You may want to check what codecs your earbuds support before doing so. But because the issue is affecting multiple Bluetooth Devices, we're highly likely dealing with a faulty Bluetooth module. Don't hesitate to shoot me a PM if the problem persists even after changing codecs.
     
  5. Spectre32787

    Spectre32787 New Member

    Ok. So I noticed the default codec is not "Use System Selection"

    When I change the Codec to Qualcomm aptX audio, the buds work just perfectly fine but the moment i exit Developer Options, the codec switches to SBC and I lose audio.
     
  6. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    The buds don't have built-in support for that particular codec if the settings don't stick. But because other Bluetooth devices have connectivity issues, there's not much that we can do from here. By the way, is the noise isolation/noise-canceling feature something you can turn off? If so, have you tried manually disabling it?
     
  7. Spectre32787

    Spectre32787 New Member

    Things appear to be working now.

    I don't exactly understand it yet but as long as the Use System Selection is selected, the devices are working and the settings stick. It wasnt doing this before. I am still confused but so long as it works I am fine
     
  8. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    It would be rather difficult to tell what's actually going on without the device on hand. But if it works, it works right? Anyways, I'll be locking this thread as resolved, but feel free to PM me should you need assistance with this in the future. See you around!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >