2018 Razer Blade 15.6 + Razer Core X 1080ti?

Discussion in 'Systems' started by Sonnyoi, Sep 14, 2018.

  1. Sonnyoi

    Sonnyoi Active Member

    I recently purchased the 2018 blade 1060, how to choose to run off the Core when it is plugged in, seems to be running off the internal GPU, anyone?
     
    ricstar and LeMinh97 like this.
  2. Joikansai

    Joikansai Well-Known Member

    Try instal same driver after plugged in. First day I had also issue, not that though, after unplugging I’ve to reinstall driver for dGPU in Blade. Doing that solve the issue, it’s with v2 but basically same, i also use gpu switcher beta, not specifically for Blade 15 but it’s working, and better than nvidia switch gpu controller or doing manually through device manager imo.
     
    imReqi, LeMinh97 and Sonnyoi like this.
  3. Sonnyoi

    Sonnyoi Active Member


    It workedddddd :heart:Just ran benchmark with the 1060 vs Razer Core X + 1080ti oh my the performance gap! XD
     
    LeMinh97, imReqi and Joikansai like this.
  4. imReqi

    imReqi Active Member

    I'm following you man! I ordered my Core X yesterday and it shipped today. So excited to get that up and running alongside the new Blade. Thanks for posting your issues and fixes so I can hit the ground running when it gets here!
     
    Sonnyoi and LeMinh97 like this.
  5. Sonnyoi

    Sonnyoi Active Member

    Mainly simple things, So far no problems just needed to learn how to swap to GPU in the Core, here is the link for the Razer GPU Switcher so you do not have to go looking for it!

    http://drivers.razersupport.com/ind...73.1878686852.1527625142-507241658.1527009296
     
    imReqi likes this.
  6. Firebat246

    Firebat246 Well-Known Member

    You should share some benchmarks with us
     
    Sonnyoi likes this.
  7. Sonnyoi

    Sonnyoi Active Member

    I already have in a new post :)
     
  8. Joikansai

    Joikansai Well-Known Member

    Sonnyoi likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >