Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

2nd Monitor Support for Razer Blade (1060GTX / Intel 7700) on Antergos

Discussion in 'The Linux Corner' started by ryanisnan, Mar 17, 2017.

Thread Status:
Not open for further replies.
  1. ryanisnan

    ryanisnan New Member

    Hi there,

    I'm trying to get my razer blade working with a second external monitor over HDMI and am having some trouble.

    I'm using Antergos on my new Razer Blade (14", full-HD). I'm currently dual booting Win 10 (default install) alongside Antergos using Grub.

    I've installed the Nvidia drivers using pacman as well as the ACPI tables fix for Optimus cards here: https://github.com/m4ng0squ4sh/razer_blade_14_2016_acpi_fix

    ➜ ~ pacman -Q | grep nvidia
    nvidia 378.13-3
    nvidia-settings 378.13-1
    nvidia-utils 378.13-5

    I can get bumblebee running, and it appears my card is working. Here's the (relevant portions) of ouput of lspci -v

    00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04) (prog-if 00 [VGA controller])
    Subsystem: Razer USA Ltd. Device 6755
    Flags: bus master, fast devsel, latency 0, IRQ 324
    Memory at db000000 (64-bit, non-prefetchable) [size=16M]
    Memory at 70000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915


    01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Razer USA Ltd. Device 6755
    Flags: bus master, fast devsel, latency 0, IRQ 328
    Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Memory at c0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000
    [virtual] Expansion ROM at dd000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia


    I've tried removing nouveau (removed the xf86-video-nouveau package and ran modprobe -r nouveau), but I'm still puzzled why the kernel module nouveau is still in use.

    Anyways, I can get into nvidia-settings using the following command:
    sudo optirun -b none nvidia-settings -c :8

    I cannot for the life of me get the system to detect the external display, though.

    Here is the output of xrandr.

    ➜ ~ xrandr
    Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
    eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
    1920x1080 60.05*+
    1400x1050 59.98
    1280x1024 60.02
    1280x960 60.00
    1024x768 60.04 60.00
    960x720 60.00
    928x696 60.05
    896x672 60.01
    800x600 60.00 60.32 56.25
    700x525 59.98
    640x512 60.02
    640x480 60.00 59.94
    512x384 60.00
    400x300 60.32 56.34
    320x240 60.05
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-1 disconnected (normal left inverted right x axis y axis)


    Help would be greatly appreciated!
     
  2. PeteHamlin

    PeteHamlin New Member

    Hello there!

    Do you know if you're getting the connection event trigger when plugging the monitor in?

    Try running
    Code:
    cat /sys/class/drm/card0-HDMI-A-1/status
    both with and without the monitor attached, and see if you get anything different (I'm guessing no, but worth covering all bases first)?

    May also seem like a derpy question, but assuming the monitor is working fine with the windows partition?

    And finally, have you tried disabling the main laptop display and forcing the display through to the secondary monitor, both in desktop mode and just as a shell? (multiple ways to do this, starting with easy, such ans hitting fn + F4 getting progressively more complex/dangerous :stuck_out_tongue_winking_eye: )
     
  3. toxicious

    toxicious New Member

    I have been battling the same issue since I got mine last week. No idea how to solve it. I get the same xrandr output as you do. If I switch to the NVIDIA card in the nvidia-settings, the external monitor is detected (but sadly there's a bug in Unity 7 that makes it hard to use both internal and external monitor). So I can use just the external monitor on the NVIDIA card fine. But yeah, that means I have to switch back to Intel every time I am on the move. Such a hassle. I am guessing that the HDMI port is connected directly to the GTX, and that the NVIDIA driver for Ubuntu doesn't include the necessary code for forwarding that port to the Intel Graphics. I'm hoping a solution will appear soon though.

    And yes, everything works fine in Windows.
     
  4. ryanisnan

    ryanisnan New Member

    Thanks for the response Pete.

    So running cat /sys/class/drm/card0-HDMI-A-1/status yielded the same 'disconnected' when plugged in and unplugged.

    The windows partition is working just fine, so it seems purely like a software issue.

    I have not tried anything like you suggested yet. My nvidia-settings window (run using sudo optirun -b none nvidia-settings -c :8) doesn't seem to pick up the external monitor at all. Here's a snapshot of my display config.

    upload_2017-3-21_14-2-16.png

    Thanks for all of the help.
     
  5. PeteHamlin

    PeteHamlin New Member

    Hey, sorry for the late reply.

    Just a couple of other questions, are you using the default Gnome desktop? Also, may be worth trying another distro and see if it works with one of those, that way you can narrow it down to a kernel/hardware issue or just a flavour issue.

    If you get the chance to try and force the display through just the external monitor, let me know how it goes. I know certain desktops (namely unity) struggle with the whole multi monitor thing on laptops sometimes.
     
  6. FeiLee

    FeiLee New Member

    Hi, I bought mine a few month ago and installed Gentoo. AFAIK there is an issue with the intel skylake chip and does not detect the external output. I'm still searching for a solution.
    If it helps, you can work around this by setting a pure nvidia configuration (disable the intel and nouveau support). Using the nvidia driver works fine with external monitor, but the battery drains in less than 2 hours.
     
  7. I just got this working on Manjaro after a lot of reading and fiddling with things. Here are the steps I took:

    1. install the bumblebee nvidia drivers (I just used the GUI in manjaro settings -> hardware)
    2. run
      Code:
      intel-virtual-output
      at the terminal. It starts a daemon that looks for an external monitor connecting
    Yeah it was that easy -_-
    This is on manjaro gnome if that matters.
    I also updated the kernel to the latest but I'm not sure if it's needed for this to work.
    It's possible that some other thing I did before was also necessary but I don't think so.
    I plugged in my 1080 tv and it extended the desktop automagically, but the resolution was only 1024x768 and didn't have the option in the GUI to resize. I tried using xrandr to set it to 1920x1080 but it just disconnected. Ill probably have to mess around some more with xrandr but at least the output works.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >