7.1 not working, Razer Kraken 7.1 v2

Discussion in 'General Discussion' started by XRamon97X, Apr 1, 2021.

Thread Status:
Not open for further replies.
  1. XRamon97X

    XRamon97X New Member

    Hello, I post because I'm having problems with my Razer Kraken 7.1 v2, headsets that I bought a few years ago and worked perfectly until now. One day, maybe after a windows update or something, I lost the 7.1 sound, I mean, I can hear the sounds but like mono, without the 7.1.
    Tried reinstalling and updating drivers, reinstalling Razer Synapse 2 too, but I can't even hear the Synapse calibration tests.
    The only way to hear again the 7.1 sounds it's using the Spatial Sound with Windows Sonic, Dolby Atmos for Headphones or DTS:X. The two last are not free software, and the first sounds horrible.
    I want to hear again the 7.1 like before, and I've noticed that in the Sound -> Headsets properties -> Spatial Sound there was a checkbox called "Activate 7.1 virtual surround sound" that now have disappeared.
    I tried to install the Razer 7.1 Surround Sound software too, but needs a code that I don't have inside the box or in razerid.razer.com (but I have never needed it before anyway, so install it it's not an option).
    Need help, thank you.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >