Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Abyssus V2 dead on iMac (but works on Windows)

Discussion in 'Mice and Surfaces' started by TeddyMac, Mar 11, 2017.

Thread Status:
Not open for further replies.
  1. Olivewebpoly736

    Olivewebpoly736 New Member

    For the past weeks I've been using the Abyssus moue on my iMac without any issues.

    Yesterday, all of a sudden, it stopped working (on Mac): i.e. the cursor is not moving AND the mouse's LED light is not lit! It appears to be bricked/dead even though I did NOT update its firmware...

    But, it works absolutely flawlessly on Windows.

    So I'm assuming its a problem with my Mac. I've tried to reset:
    • SMC; and
    • NVRAM ...
    ... but my mouse is still not working.

    Any suggestions?

    My OS: macOS Sierra ver 10.12.3
     
  2. Predator5

    Predator5 Well-Known Member

    Maybe the USB port isn't working. Try plugging a USB Stick into it to check the USB port.
     
  3. Olivewebpoly736

    Olivewebpoly736 New Member

    All USB ports are working great when tested with other devices.
     
  4. RaptureHearts

    RaptureHearts Gamer Geek Girl

    Contact our support team through http://rzr.to/help so they can see if they can assist you with your Abyssus V2 having problems on your iMac.

    Since Razer Insider is not a support-related forum, I will be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >