Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

balnk login page on razer central

Discussion in 'Razer Support' started by NicoG04, Oct 21, 2019.

Thread Status:
Not open for further replies.
  1. NicoG04

    NicoG04 New Member

    Hello i am using razer products for a while now and never really had issues. But today, razer central was logged out as I opened my pc and when i click on login I have a blank page that isn't loading. I tried to repair the program seeral times but it didn't worked. I am living in China maybe it is the fact that razer server has been banned ? it has always worked with me before. I also tried to login on my other device (not from razer) and it didn't worked as well. Can someone tell me if it is the razer server's prblem or a problem on my side ? I have waited several hours for the blank page to load but nothing
     

    Attached Files:

    KMoharram likes this.
  2. KMoharram

    KMoharram New Member

    Same problem for me...did you manage to find a solution?
     
  3. NicoG04

    NicoG04 New Member

    No I haven't and I really hope it can be fixed quick if it is on razer's side because I can't set my pc on normal mode so my bateery is draining even quickier than before
     
  4. NicoG04

    NicoG04 New Member

    Hope someone could help please
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there guys! Have you tried connecting to another network to see if the issue persists? Let me know how it goes.
     
  6. Ruthadelle

    Ruthadelle New Member

    hi admin, what do you mean connecting another network? im from malaysia....i too experience blank screen when i try logging in.....
     
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! What I meant was to use another network connection to connect to the internet. When di this issue start for you? Was this working before? Have you tried repairing the program?
     
  8. Ruthadelle

    Ruthadelle New Member

    hi admin,

    i have try using another connection (home and office)....both also show the same...i am not sure when it start cause but i only realize 3 weeks ago, that is when my laptop keyboard colour setting is not what i previously set. So i try log into razer (which usually it does automatically) that is when i saw it BLANK for a very long time..

    further what do you mean repair?? (seriously i dont know, i am a layman...any service centre i can sent to in Malaysia?)

    Cause the last i remember is when i update the system...

    razer central : 7.3.22.122
    razer synapse : 3.4.1015.100206

    that is when i experience this...i saw few fellow Razer user also have this issue...so i want to know how they fix it or how can it be fix....Tq very much and shall wait for your reply
     
  9. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please PM me here. I'll assist you from there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >