Barracuda X 2021 dongle stopped working

Discussion in 'Razer Support' started by depotDeepKoamaruquick157, Nov 29, 2022.

  1. The USB-C dongle for my Razer Barracuda X (2021) has suddenly stopped working.

    What happens:
    • USB-C dongle plugged in: Windows detects and labels the audio device as "Razer Barracuda X" (even if headset off). This can be opened in sound control panel and Windows registers it as outputting sound (but no mic) even though no sound is comes from the headset.
    • AUX cable plugged in: Works as intended.
    What I've tried:
    • Downloaded:
      • Razer Synapse,
      • Razer Headset Pairing Utility,
      • Razer Appengine - THX Spacial audio,
      • Realtek audio console,
      • Barracuda X Firmware updater.
    • Razer Barracuda X Firmware updater: Launched as admin, plugged in dongle and cable, software shows as working, notes that update is needed (Headset version = 1.4.0 (Latest 1.4.0), Dongle version = null (Latest1.4.0)) and begins updating only to stop repeatedly at 90% until finally returning "Pairing failed."
    • Razer Headset Pairing Utility: Launched as admin, plugged in dongle and cable, software normal, returns "Pairing failed."
    • All firmware and drivers are up to date. Relatively new computer with no bloat, etc. Relatively new headset (April) with no physical damage.
    Can anyone advise on what else I can do? I don't want to waste money buying a new one, especially if this is a common occurrence. Buying a new dongle is inaccessible and almost half the price of a entirely new Barracuda X (In Australia).

    Thanks.
     
  2. I have the same situation, I also tried a lot of things while using 3.5. Nothing helps.
     
  3. FiszPL

    FiszPL Well-Known Member VANGUARD

    I'd try clean synapse reinstall with Razer drivers removal:
    1. Uninstall Synapse
    2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
    3. Then restart your PC
    4. After reboot install Synapse again (as administrator).
    I'd also check the dongle on other PC - is it properly recognised - if yes, then I'd try pairing utility one more time.
     
  4. Did. It didn't help. It doesn't work on another computer either. Very bad connection at the beginning, then does not catch at all.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >