Basilisk double click issue

Discussion in 'Razer Support' started by SteelTealhitsite609, Mar 2, 2021.

Thread Status:
Not open for further replies.
  1. SteelTealhitsite609

    SteelTealhitsite609 New Member

    Hi Support, I have an issue with my new Basilisk mouse - when I click on left button it double clicks occasionally. I have tried to play with mouse settings in windows and it does not help. Also I have updated/uninstalled Razer software and it does not help.
    How this could be fixed?

    Thanks
     
    AnipR15 likes this.
  2. Thomas_Raven

    Thomas_Raven New Member

    I have the same issue and I can see a few similar threads here, no solution so far. I'm using My Basilisk X via 2.4 on both company laptop and private PC, issue is the same. I've tried to reduce sampling to 500 and then 125, helped a little, but problem still persist. It seems to be OK on Bluetooth, so it's not a button issue, but I haven't used Bluetooth for long (it keeps loosing connection, so I gave up).

    I've updated firmware, software, checked different USB ports, checked power saving options, mover away from router, run out of ideas, nothing has changed.

    The are some advises on other forums to completely remove the Synapse driver, but I need extra buttons for my work, so that's not a solution.

    Same issue:
    https://insider.razer.com/index.php...-mice-automatically-resets.71248/#post-735895
    https://insider.razer.com/index.php...le-multiple-clicking-issue.70415/#post-734793
    https://insider.razer.com/index.php?threads/razer-basilisk-x-hold-issue-dropping.63629/

    Looking forward to Razer's answer.
     
  3. xautoFirebrick565

    xautoFirebrick565 New Member

    I have the same issue here. I tried the firmware update and some click speed settings, but nothing works. It has been like 1 year since I bought this mouse. I`m very disappointed.
     
  4. Thomas_Raven

    Thomas_Raven New Member

    I've managed to repair my mouse. I've noticed that issue depends on how hard I press the button so I pressed it really hard. Miraculously, since then button works fine. So it must be a manufacture issue with these buttons.
     
  5. jw404

    jw404 New Member

    Same issue here with my left-click on a Trinity. I actually bought this one to replace another Razer mouse with the same issue.
     
  6. AnipR15

    AnipR15 Member

  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey AnipR15! Thank for the tag.

    Hey everyone! Please check if the double-clicking issue happens while the Razer Synapse 3.0 is disabled or closed. Try resetting the device via Razer Synapse 3.0's settings too. I'll be locking this thread now. Don't hesitate to send me a PM or visit our self-help options should you have other questions or concerns.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >