Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Basilisk polling rate does not change

Discussion in 'Razer Support' started by And54432, Jan 27, 2019.

Thread Status:
Not open for further replies.
  1. And54432

    And54432 New Member

    DRIFT_IT and 0V3R_K1LL like this.
  2. FiszPL

    FiszPL Well-Known Member

    Try "mouse rate checker" app, not the web based app - it's working on JS, and each browser is parsing JavaScript slower or faster.
     
  3. And54432

    And54432 New Member

    I already try executable app, but same result
    I think this is synapse 3.0 bug and it happen to all basilisk users but they dont notice this problem because almost people usually dont measure polling rate including me.

    If you have basilisk, could you check polling rate for me?

    I find out no need to reboot PC. just restart synapse 3.0 then actual polling rate goes down to 500hz.

    video:
     
    Last edited: Jan 28, 2019
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hey @And54432! I know I'm a bit late to the party but I'd like to help you out. Have you tried reinstall Synapse or switching to another mouse profile? If you haven't yet, please do so and send me your results via PM so we can further isolate the issue.
     
  5. hypov8

    hypov8 New Member

    i have a basilisk to.
    for me its been a bit hit and miss to achieve the 1000hz poling rate.
    it seems as soon as the synapse loads fresh it sets it back to 500hz for me to


    the problem has existed since the very first install of synapse 3. multiple re'install didn't do jack..
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >