Battery issue on Razer Blade 15 Advance Late 2019

Discussion in 'Razer Support' started by Im_Geor, Apr 3, 2020.

Thread Status:
Not open for further replies.
  1. Im_Geor

    Im_Geor New Member

    Hi.

    I’ve got my Razer Blade 15 for just over 2 months but now my battery don’t work anymore.
    I can’t use my laptop if it isn't connected to the wall and if I unplug my charger, the laptop turn off immediately.
    It also shows this icon:
    upload_2020-4-3_18-0-19.jpeg

    I already tried uninstalling and reinstalling the driver of the battery and it doesn't work.
    When I click the icon it shows that is at a 100% and if I hold the arrow of my mouse over the icon it says this:
    upload_2020-4-3_18-3-6.png

    But the truth is that when I unplug the charger the laptop shuts down immediately.
    I already experienced this before this post but it fixed itself with one of the Security Intelligence Update of Windows Defender antivirus, so I've been patiently waiting for some patch or something because this happened one day randomly but I can't wait anymore, it seems like a bad joke. I haven't even moved the laptop from my desk in all this time!

    Can you help me please ? If the battery is dead... you gotta be kidding me. It's only been 2 months, come on.
     
    Sulltron likes this.
  2. Sulltron

    Sulltron New Member

    Having the same issue - battery won't charge and it's now at 0%. I can run on the AC adapter but running any games causes the power to fail (assumed from increased power consumption causing a total failure).
     
    JSReijnoudt likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >