black screen on razer central login page

Discussion in 'Razer Cortex' started by byharu, Dec 6, 2022.

  1. byharu

    byharu New Member

    I installed razer cortex along with the razer central. However, when I try to open cortex a black screen pops up so I cant login/use it at all. I tried some stuff I found online but nothing worked. upload_2022-12-6_13-7-27.png
     
    M33M0 likes this.
  2. Krissy-RCD

    Krissy-RCD Member Staff Member

    Hey there!

    Thank you for sharing your issue with us via this thread. I'm Krissy. I'm happy to assist you with your issue.

    Regarding your issue, please follow the below steps to troubleshoot:

    1. Ensure the internet connection is good.
    2. Please clear the cache by deleting this folder: C:\ProgramData\Razer\Razer Central\WebAppCache
    3. Ensure that no anti-virus/VPN software is running when you log in to Razer Cortex.
    4. If the issue persists, please check for host file information C:\Windows\System32\drivers\etc\hosts, open it with notepad, and if id.razer.com has some IP assigned to it.
    5. Check if you are able to access https://id.razer.com/

    Thank you! We apologize for the inconvenience this issue has caused you.

    The Razer Cortex PC Team
     
  3. byharu

    byharu New Member

    None of it worked, and yes I am able to access https://id.razer.com/
     
  4. Krissy-RCD

    Krissy-RCD Member Staff Member

    We sincerely apologize for the inconvenience this issue has caused you. The engineering team is reproducing and fixing this issue now. We may need more time to resolve this.

    We truly appreciate your patience and feedback.

    Krissy
     
  5. manpreetsnehra

    manpreetsnehra New Member

    I have been having this issue for almost a month now. No success. Here is how to reproduce the issue
    1. Install Windows on a VM(kvm) without any razer hardware plugged in
    2. Install synapse and start.

    That's it. if you fix this issue synapse will become useful not only for doze users but also for linux users since they can use the VM to configure the macros.
     
    M33M0 likes this.
  6. chema428

    chema428 New Member

    same problem here,i tried all
    on windows
     
  7. manpreetsnehra

    manpreetsnehra New Member

    Very poorly developed/tested application. Base QA should help it work in worst conditions instead of best conditions.
     
  8. Krissy-RCD

    Krissy-RCD Member Staff Member

    Thank you for providing the details. Our engineering team will reproduce this issue with the method you provided. We sincerely apologize for the inconvenience this issue has caused you.

    Krissy
     
  9. Did someone find any solutions? I created a account just because of this.
     
  10. Krissy-RCD

    Krissy-RCD Member Staff Member

    Hey there,

    We have sent you a new installer via PM. Please check it. Thank you! We sincerely apologize for the inconvenience this issue has caused you.

    Krissy
     
  11. _Make2d

    _Make2d New Member

    Hi Krissy, Im having the same issue as well. Would I be able to receive the new installer? Thanks!
     
  12. Krissy-RCD

    Krissy-RCD Member Staff Member

    I have sent the new installer to you via PM. Please check it. Thank you!

    Krissy
     
  13. RadarK19

    RadarK19 New Member

    I'm having the same issue.
     
  14. JackToncatridr

    JackToncatridr New Member

    I get this after rebooting my computer once I've installed Synapse, maybe not the first time I reboot, maybe not the second, but I get it consistently... Reinstalling doesn't always work, but this is the 4th time Synapse has broken like this, and it's really getting on my nerves.

    I'm unable to use any of the features of Synapse 3 or Cortex or anything that require me to be logged in..

    Razer Central v. 7.3.11.110 Razer Synapse v. 3.4.401.32710 Razer Cortex v. 9.4.13.995
     
  15. alt_alf

    alt_alf New Member

    how to fix this? i have the same problem.
     
  16. PM2116H19435856

    PM2116H19435856 New Member

    It is a wild guess, still many applications showed a black on my system lately. Trying to pinpoint the issue, playing with screen settimgs i noticed all applications displayed on my old secondary monitor with no issues. Suspecting a corrupted GPU driver (AMD prereleases are prone to show all kinds of strange behaviour) i did a clean install. Nevertheless the problem perisisted. I could start on a (much too large) window on the old screen and drag it over. Long story short in the end the culprit turned out to be MS auto HDR feature on Win11 which i had to disable manually for affected applications.
     
  17. alt_alf

    alt_alf New Member

    it don't help me
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >