Black Widow V3 PRO keyboard connection 'flickering' causing split-seccond loss of function

Discussion in 'Razer Support' started by aoyston, Mar 16, 2021.

Thread Status:
Not open for further replies.
  1. aoyston

    aoyston New Member

    Moderators please notify if there is a specific sub-thread for this (couldn't find one).

    I recently got a Black Widow V3 PRO keyboard, occasionally it will disconnect and reconnect over a split second. I have only noticed as I when gaming (COD) I will stop moving due to this.
    I have checked all drivers are up to date.
    I've worked out it is the keyboard as I changed the backlighting to static, and you see the lights flicker at the same time as the movement stopping in the game.
    It's becoming more of a frequent issue.

    I've tried changing the port the dongle is to make sure it's not the port, still occurs.

    Wondering if anyone else has experienced this? If so, have you been able to rectify?
    I've submitted a support case to Razer, but hoping someone else may be able to shine some light.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Do you get the same results with and without Synapse running in the background, and is your WiFi network broadcasting on 2.4 or 5 GHz? In any case, please send me the serial number so I can check for possible firmware-related solutions.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >