Blackshark V2 microphone will not reconnect!

Discussion in 'Razer Support' started by Beardfaceboy, Feb 5, 2021.

Thread Status:
Not open for further replies.
  1. Beardfaceboy

    Beardfaceboy New Member

    I received a pair of Blackshark V2s for Christmas, and they have been working flawlessly until recently. I picked up a Logitech C922x Pro Stream Webcam, which was easy enough to set up. Was having some issues with the built in microphone on the camera, and after messing around with the inputs, and not having any luck, I just stuck with the headset's mic for my game that night. Now I suddenly have the opposite problem! The mic on the camera will pick up audio, but the headset's mic, which is still showing up in my "inputs" menu, will not pick up any sound at all.
    I have tried restarting, I have disconnected and reconnected, and yes, the microphone volume is on.
    Any thoughts?
     
  2. Beardfaceboy

    Beardfaceboy New Member

    Specs of my system just in case:
    CPU:
    INTEL Core I5 10600k
    CPU Cooling:
    MSI Core Frozr L 71.27 (air)
    GPU:
    NVIDIA MSI 1660 ti Gaming X
    RAM:
    16GB Corsair Vengeance RGB 3600 mhz (CL 18)
    Motherboard:
    MSI MPG z490 Edge Micro Atx WIFI
    Primary Drive:
    SSD Corsair Force MP510 480gb M.2
    Secondary Drive:
    Seagate Barracuda 2TB HDD
    Power Supply:
    Corsair RM 750w 80+ Gold
    Case:
    MSI Gungnir 110R
    OS:
    Windows 10 - 64 bit
    Display:
    1x MSI Optix MAG270VC2 27 inch (1920x1080 at 165hz) and 1x MSI Optix MAG270QF (2560x1440 at 144hz)
    Headset:
    Razer Blackshark V2
    Speakers:
    Bose Companion 2 (Series 3)
    Webcam:
    Logitech C922x Pro Stream Webcam
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >