Blackshark v2 (or usb sound card) causes audio delays when using Discord

Discussion in 'Razer Support' started by Developer195, Aug 1, 2022.

Thread Status:
Not open for further replies.
  1. Developer195

    Developer195 New Member

    Hello there,
    I have this weird problem with my Razer Blackshark V2 headsets or with Razer USB Sound Card. Whenever I'm using Discord the voice chat audio is delayed, cuts off or speeds up. It's hard to describe, but I see my friend's icon lights up when he is saying something, but one of the following things happens:
    - his audio is delayed for a few seconds, in some cases it's 2 or 3 seconds in other cases it's 20 seconds,
    - delayed voice audio then is delivered with x2 or x3 speed
    - delayed voice audio is simply lost
    And this happens whenever I'm using Discord. When watching YT, Netflix or simply playing games the audio is clear and beautiful.
    I tried everything... Fresh system install, fresh Synapse install, fresh Discord install, fresh drivers install... Nothing works.

    PS. I tested voice chat in 4 games and it works perfectly well there.
     
  2. Razer.Zionzedd

    Razer.Zionzedd Yes, My lord? Staff Member

    Try to reinstall its driver and update the firmware by following the steps here. If that didn't help, PM me the serial number so I can validate its model and look for other steps to help you resolve the audio delay issue.

    *Thread locked to curb conversation to PM.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >