Blackwidow Chroma is not working anymore?

Discussion in 'Razer Support' started by Emircho, Jan 24, 2019.

Thread Status:
Not open for further replies.
  1. Emircho

    Emircho New Member

    Hello everyone, unfortunately my blackwidow keyboard is not working anymore. Everything was fine, next day i open PC, no lights, keyboard is not responding. I had to open the windows keyboard feature to put my password and unlock my PC. Tried removing synapse 2, reinstalled. Then ditched it completely and now i'm using Synapse 3. But the problem is, it is not shown in the devices, firefly is there, mamba is there but no blackwidow. And i don't think this is synapse related because, it is not even working at the opening where you can push DEL to go bios settings. So i'm thinking probably it is not getting any power or maybe it's just broken inside. Is this repairable, has anyone ever experienced something like that before?
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Let's isolate the issue. Please try to plug it into another port or PC and see if the same thing persists. Let me know how it goes.
     
  3. Emircho

    Emircho New Member

    I tried every ports, tried all the clean install of synapse, talked with razer support. Funny thing is, it is even going more crazy now. It is constantly connecting and disconnecting itself. Like non stop, 20 times in a row... Then stops for couple of minutes, then goes crazy. Totally random, and its last attack was so annoying i completely removed the plug, later i plugged it again and now it is completely gone. But even with my every try, i can only bring the keyboard alive this much. I am thinking know it might be hardware related which i wouldn't expect from Razer quality product but well nothing we can do about that. I'm gonna try to plug this keyboard to another PC whenever i can and see if it's actually software problem or hardware...

    Because i don't think you ever seen this kind of problem before. Internet has a lot of posts about this constant connect/disconnect problem but no solution so far.

    Oh it is going like crazy. For more than hour it has been going now, non stop. Windows USB port connect and disconnect sound is now truly annoying to me.
     
    Last edited: Jan 28, 2019
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Let me know how it goes with another PC. If you can also give me the case number through PM, that would be great.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >