Blackwidow Chroma V2 not lighting up since Synapse update

Discussion in 'Razer Support' started by Akimbowles_Rangers, May 15, 2019.

  1. Akimbowles_Rangers

    Akimbowles_Rangers Active Member

    As the title says, since the latest Synapse 3 update, my BW just won't light up.
    Upon start-up of my PC, it will glow with the spectrum cycling stuff as it always has (proving it isn't broken), but as soon as Synapse launches, the colour disappears.

    For months I have been using the same lighting profile in Synapse Studio and it has worked fine (all razer devices set to RGB wave), and I've never had an issue. Until this update.
    Now it won't recognise any input from Synapse. I've tried changing the profile, tried changing the effect, tried changing the colours, restarted Synapse, restarted my PC, everything. There's no logical reason why it works only until the software that's designed to make it work starts...

    Anyone else experiencing this issue/something similar?
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    That's not supposed to happen and as much as I hate to say it, have you tried reinstalling Synapse? Please do send me a PM with your Synapse build version along with the serial number of your keyboard so I can look into model-specific fixes.
     
  3. Akimbowles_Rangers

    Akimbowles_Rangers Active Member

    I had tried reinstalling Synapse, yes.
    Strangely enough, for no reason whatsoever, it started working again yesterday. I didn't do anything differently so couldn't even begin to tell you how it got fixed.

    Thanks for your help though! :)
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    I can't complain if that's the case but don't hesitate to send me a PM should it ever reoccur. :wink_:
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >