Blackwidow Elite not detected in BIOS nor Windows 10

Discussion in 'Razer Support' started by madispuk, Jan 28, 2020.

Thread Status:
Not open for further replies.
  1. madispuk

    madispuk New Member

    My Blackwidow Elite keyboard used to work perfectly, but suddenly stopped working after restart - no lights, nothing.
    I have windows 10. It does not get detected in Synapse 3, also it does not get detected in BIOS (worked before). If I plug it into any other machine, it lights up and works perfectly. Other USB keyboards in my PC are also working fine so it's not a problem with the port.

    I have tried basically everything, removed Synapse with manually deleting all Razer folder, stopping Razer services, uninstalling drivers in Device Manager, trying to find registry elements to clean up etc. Reinstalled it at least 6 times. Tried all differed USB ports.

    Does it have some software running inside? Maybe it was automatically updated and something broke down.
    I'm running out of ideas how to debug. I can't find where to get older versions to test...

    Do you have any idea?
    Cheers.
     
  2. madispuk

    madispuk New Member

    Tech support, is it possible that because of corrupted (?) keyboard software BIOS is not able to detect it anymore?
    I'm starting to believe that it doesn't have anything to do with Windows and drivers because it's not working in BIOS either. Somehow BIOS is not picking it up. I tried to reset BIOS by removing the battery and also updated BIOS version. All other USB keyboards are detected, so the settings should be fine.
     
  3. madispuk

    madispuk New Member

    It was the PSU power cable. Believe it or not. I tried 2 different ones that didn't work. When I got back the "original", the keyboard started to work instantly. Glamorous.
     
    Razer.Speedcr0ss likes this.
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for sharing this on our Support board. Feel free to send me a PM should you need additional assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >