Blackwidow V2 lights not lighting up

Discussion in 'Razer Support' started by JOS3COSTA, Jul 15, 2021.

Thread Status:
Not open for further replies.
  1. JOS3COSTA

    JOS3COSTA New Member

    Hi. I currently have a Blavkwidow V2 and yesterday the lights stopped. None of the lights work, Neither the caps, num pad and scroll lock lights on top of the num pad work. I tried uninstalling the razer synapse, unplug the keyboard and put it in a different usb slot and none of that worked. I hope someone has a solution. Thanks
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you using the Razer Synapse 3.0? If you are, please reset the keyboard through the app's settings by clicking the gear icon at the top-right and look for "Reset". Also, check if the same behavior happens when logged in as a guest user in the Razer Synapse 3.0. Feel free to submit a case to our Support Team or send me a PM should you need additional assistance. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >