Blackwidow v2 not wont turn on

Discussion in 'Razer Support' started by EndlessNameless, Feb 15, 2019.

Thread Status:
Not open for further replies.
  1. EndlessNameless

    EndlessNameless New Member

    Hi all,

    I am posting this on behalf of a good friend. his blackwidow v2 has just randomly just stopped working, we have tried the usual troubleshooting steps, such as deleting everything form device manager, uninstalling synapse, etc...Synapse is not detecting his keyboard at all.

    has this ever happened to anyone before and is there a fix that anyone knows of?

    hopefully this can be fixed and will not need to result in a RMA. any advice will be much appreciated :)

    thanks in advance
     
  2. off3nc3

    off3nc3 New Member

    Yea this happened to me last night after resetting my Windows 7 for the 20th time while trying to get synapse 3.0 to see my BlackWidow Chroma Tournament V2 and brand new Naga trinity to no avail. Now the keyboard works but the RBG leds don't light up anymore and synapse 3.0 still doesn't see anything.

    The only thing that worked was connecting my keyboard to my laptop and installing synapse 2.0 then putting it back in my desktop unit..

    No comment on how badly these drivers are and razer support is abysmal.
     
  3. EndlessNameless

    EndlessNameless New Member

    thanks for replying...this morning it just started working again out of no where, which is even more strange.

    synapse is getting worse with every update. personally I haven't had any keyboard issues, mine have been more to do with my Nari and mamba hyper flux. Razer sell you the most expensive peripherals you can buy, then make you use them on broken beta software....disgusting move
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >