Blackwidow X Chroma disconnecting when moved

Discussion in 'Razer Support' started by bizPaleGreenlink798, Jun 7, 2018.

Thread Status:
Not open for further replies.
  1. bizPaleGreenlink798

    bizPaleGreenlink798 New Member

    I have a Razer Blackwidow X Chroma for more than a year now and had no problems until two days ago. Suddenly the keyboard disconnects while typing rapidly.
    When it disconnects, the keyboard lighting goes out, I hear the windows device-disconnect-sound and it becomes unresponsive for a short amount of time (1-3seconds I guess).Then it reconnects, the lighting comes back and I hear the Windows device-connection-sound.
    This problem occurs sometimes while typing (I think it's when I unintentionally move the keyboard while typing), and when I intentionally move it. But it varies how much force/movement is needed to have it disconnect. In an attempt to reproduce, I swung it through the air and there was no connection loss, and then other times the slightest movement leads to connection loss.
    I have tried three different USB-Ports, and nothing changed, also moving the cord doesn't lead to connection loss, but moving the keyboard itself does.
    I would guess it is a loose connection, but I'm not that good with these things. What could it be? And how could I repair it / what can I do about it?
    Thank you very much in advance!
     
  2. FatKidWanderer

    FatKidWanderer Well-Known Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >