Blackwidow X Chroma with Lancehead TE

Discussion in 'Keyboards' started by edeltraut2k, Aug 5, 2017.

Thread Status:
Not open for further replies.
  1. Heyho,

    first of all sorry for my bad english - im from germany and i guess i have to speak english here?!

    Im using the Blackwidow X Chroma since 8 months with a Razer Naga which is much older tho.
    I edited my lightning profile (waves with my colors and a bit slower) and had no problems with using both devices.

    Now it was time to get me a new mouse so i bought the Lancehead TE and the problems begin.
    After plugin the mouse (i thought) my already up to date Razer Synapse said there is an update. I installed the latest version and my lan driver crashed totally. I had no internet and had to reset the whole network settings under win10. Im using a MSI Z170 board with a killer lan chip (yes i know its not necessary).
    After fixing this problem.. which comes definitely from the new Razer software, my Blackwidow X Chroma
    only can uses the standard color profiles.... so im totaly disappointed.
    I can edit everything for my Lancehead TE but if I want to open the CHROMA-KONFIGURATOR on Razer Synapse for my Blackwidow X Chroma theres just a text ``Image failed to load´´ on the keyboard and if I add a new layer everything is showing grayed out. If i click apply the whole keyboard has no lightning at all.

    I'm using the version 2.21. If im clicking "search for update" in the software there is always a message "there is a newer version for Razer Synapse available" but if I click "now update" he installs something and nothing happens. I can do this step over and over again...

    I deinstalled Razer Synapse and Chroma Apps 3 times.

    So please I really dont know whats going on here.. I just bought the Lancehead to have a nice looking on my desk when everything is synchronized.

    Here is a little video of my problem. The quality is not the best but its only for showing my problem.


    Edit: and i already wrote a ticket to the support which is 3 days ago - with no answer

    Thanking you in anticipation
    Alex
     
  2. CoolOtaku

    CoolOtaku New Member

    Razer insider is NOT a support forum.
     
  3. Ok genius then just tell me what would you do after already writing a ticket to the support team?

    and by the way i was reading in an other thread that someone gets help by an official staff member for a problem like that.
     
    Last edited: Aug 5, 2017
  4. CoolOtaku

    CoolOtaku New Member

    Wait?? Follow razer rules please.
     
  5. Keep your knickers on ... I did follow the rules so whats your point? Do you want to play the chief?

    Reaching out to Support
    Razer Insider is not a support forum, community help may solve a couple of product issues, but these remedies may not be the proper, or permanent solution to your problem. We recommend going directly to our support team for expert help at www.razersupport.com/contact.

    At the same time, we will moderate support threads to keep conversation topics clean and accessible, this will include all specific product/technical issue complaints, so please refrain from starting a thread just for complaint purposes.

    So whats wrong in searching for any help out of the community if I already contact the support and get no answer?
     
  6. CoolOtaku

    CoolOtaku New Member

    2nd paragraph sir.
     
  7. please get out of this thread, chief..
    1st of all you dont get it. 2nd u even dont make an effort to post what do you mean. 2nd paragraph? SPAM?! really?

    just let guys in here who really want to help and bring in something constructive.
    thank you
     
  8. Lafar

    Lafar Well-Known Member

    @TheGeniusSide is right, Insider isn't a support forum.

    Razer Support is the best way for you to get your help, since they're the most knowledgeable ones concerning this issue.

    In accordance to the House Rules, I'm going to have to lock this support request. If Support doesn't get back to you in another few days (I'm pretty sure they don't work on weekends), feel free to reach out to me.
    If anybody else has anything pertinent to add onto this thread, also, feel free to reach out to me.

    Meanwhile, have you tried reinstalling Synapse (don't forget to restart)?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >