Blade 17 - external monitor via USB-C/Thunderbolt 4 not working

Discussion in 'Systems' started by Ribsletics, Jul 6, 2022.

  1. BlackFireDragon

    BlackFireDragon Well-Known Member

    I assume you try to factory reset bios and connect via dock only one external monitor and still it didint work ? It is little strange can you cheack dock on diffrent laptop ? this should say more if the issue is on dock or your laptop.
     
  2. SRAY95006

    SRAY95006 New Member

    upload_2022-10-20_17-44-12.png
     
  3. Still not working for me. Razer Blade 17 (Mid 21, RZ09-0406). Bios Version 1.04 NVidia Drivers 517.48 and 522.25, one monitor. I have tried every possible combination what to plug in where. Nothing works.
    Rollback to super old drivers works so it's not an hardware issue.
     
    Joikansai likes this.
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    Try again maybe it’s only server error or some bugs occurred, apparently it happened while you’re writing the post.
     
  5. BlackFireDragon

    BlackFireDragon Well-Known Member

    It's strange. In short to be clear you have last version of bios avalible for your blade, drivers for nvidia and intel graphips up to date, on direct connection monitor laptop everything works but only via dock the issue appear, with or without anying connected to the dock still issue come up ?

    I will still prefer if you can check the dock on diffrent laptop/pc if there the external monitor will work or not becose from your messages it is clear here is some sort issue now it can softwere like nvidia drivers, windows settings, corrupted file, issue with the dock etc. so it will be great to narrow where is the issue.
     
  6. SRAY95006

    SRAY95006 New Member

    The first paragraph you wrote is correct.

    I have tried 2 other laptops, connected via the Dock, and they work, but keep in mind, they are not Razer laptops running Bios v1.06, they are Lenovo and Gigabyte running the latest NVidia drivers.

    Everything on the Razer worked fine, via the Dock, until the update bios to version 1.06. There are no corrupted files, or messed up windows settings and I've tried multiple back versions of NVidia drivers.
     
  7. Lt_Usher

    Lt_Usher New Member

    I have the exact same laptop and problem, any update on a fix?
     
  8. GipsySnake

    GipsySnake New Member

    Same issue here! Again! Uuugh. I'm now trying to downgrade (again) to drivers v512.95.

    ---

    Edit: Didn't work :frown_:
     
    Last edited: Nov 5, 2022
  9. Gr0mmer

    Gr0mmer New Member

    Got the new Razer Blade 17 2022 (12800H, RTX 3080 Ti, QHD 240 Hz).
    Current BIOS version 1.07 (but how if latest on Razer downloads is 1.06?), EC FW Version 1.02. Win 11 with latest updates.

    Connecting external portable monitor - from either of the Thunderbolt 4 ports there is no signal detected, but monitor swithces on (using Razer Thunderbolt 4 Cable, connecting directly to the ports).
    HDMI to type C - same thing.

    Tried these combinations with Lenovo and Apple laptops - all working fine.

    Rollback/Updating/Studio or Game Ready drivers/Optimus or Discrete GPU - still nothing.
    Tried BIOS and EC Updater - have "This firmware tool is for use only with Blade and compatible systems. This application will now close." message - checked BIOS and surprisingly System Serial Number and System SKU are N/A - what is going on? And how to fix all of this?

    I'm working on this machine and Revert to Defaults is not an option.
    Waiting for Razer comments. Thanks.
     
    Last edited: Nov 7, 2022
    GipsySnake likes this.
  10. GipsySnake

    GipsySnake New Member

    Hey @DorGor, @Thinkfactory ! You guys still have issues with your Blades, dual external monitors, and Razer Thunderbolt 4 dock? I have a similar setup, and latest drivers did not fix these Thunderbolt + NVIDIA issues :/
     
  11. Gr0mmer

    Gr0mmer New Member

    Just up my previous message:

    1. How can I make my external monitor work with Blade 17?
    "[SUPPORT VIDEO] How to Troubleshoot External Monitor Connection Issues for Razer Blade" - not helps.

    2. Why there is no serial number in BIOS, and how to fix it? - I can't get any updates because of this thing.
     
    GipsySnake likes this.
  12. Bonebestcity253

    Bonebestcity253 New Member

    This is not resolved. I am able to confirm that this is not a Razer Dock issue - when I attach my Dell XPS 13 2-in-1 9310 to the dock the monitors work just fine.
    However when I use my Razer Blade 15 (2022) with a RTX 3080 TI, it refuses to recognize more than one external display. When I attach the 2nd monitor via the other Thunderbolt slot, the monitor works fine.
    The displays are both Dell U2515H with 2560x1440 @ 60Hz. So bandwidth should not be a problem.

    I have multiple co-workers experiencing the exact same problem on all mentioned driver versions. This makes using the Razer Blade 15 2022 unfit as a proper workstation laptop.
     
    GipsySnake likes this.
  13. GipsySnake

    GipsySnake New Member

    @Razer.Speedcr0ss good morning!

    We still have issues with external displays, and workarounds no longer work :confused:
    Any ideas? Are you able to escalate this, so it gets prioritized?

    Thanks
     
    Luckbuckets likes this.
  14. pestjay

    pestjay New Member

    i use razer blade 17 2022 with 3080ti with Lenovo USB-c dock and everything works flawlessly.
    Latest nvidia hot fix drivers, i have not done any bios updates but i think it is on the latest one as the blade was purchased on 15. September
     
  15. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey GipsySnake and everyone who still have an issue, please send me a PM or submit a case through this link so our Support Team can help us re-escalate each laptop's concern to our devs. I appreciate your cooperation.
     
    GipsySnake likes this.
  16. having the same issue as well
     
  17. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I replied to your message. By the way, I am waiting for our Support Team and developer's confirmation of what the other units are still experiencing. I appreciate everyone's cooperation.
     
  18. djphilOne

    djphilOne New Member

    having the same issue as well
     
  19. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Our devs and Support Team are revisiting the laptop's USB-C/Thunderbolt 4 behavior. The team appreciates it if you'll initiate a case number and report your unit's concern here. Otherwise, you can send me a PM so I can create a support ticket on your behalf. Thanks for your joint interest.
     
  20. Prunecovebuzz314

    Prunecovebuzz314 New Member

    I am having this same issue. I have started a support case
     
    Razer.Speedcr0ss and GipsySnake like this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >