Blade 2019 Advance Xubuntu Battery Life

Discussion in 'The Linux Corner' started by MrPuffin, Apr 20, 2019.

  1. MrPuffin

    MrPuffin New Member

    Hello everyone.

    i recently picked up a new Razer mercury 2019 to replace my aging Macbook installed a New SSD and partitioned it for Xubuntu 18.10 and Windows 10.

    the issue i'm seeing is that in Linux everything works beautiful except for its battery life.
    if i'm in windows and play a game i can play games for 3-4 Hours and general web browsing for like 5 or so
    while Linux i don't really game on it but i would like it to be my daily OS for everything but Games. but only get a little over 2 hours.

    is there some tweaks that people are aware of to get decent battery in Linux. never really run Linux on my laptops so unfamiliar with battery tweaks.
     
  2. JunleLu

    JunleLu New Member

    1. Install Nvidia 418 driver from grapic driver ppa. Use PRIME profiler option to select intel gpu only.
    2. use either powertop or tlp to tune other devices for power consumption.

    I have the 2019 4k version, and I am able to tune it with powertop to get 8+ hours battery life (reported when idling, ~10 w discharge). You should able to achieve the same or even better since your display your 1080p. I haven't tried tlp myself on this laptop.
     
    Panaman likes this.
  3. knguyen5

    knguyen5 New Member

    I've been experiencing the same thing (Ubuntu 18.04, 18.10, and 19.04) with bios v1.02. I've tried TLP to optimize the power usage, but still same result. I'm hoping that once the 1.04 bios update gets fixed (it hung on my at 99% and had to restart :eek_:, luckily nothing bricked), it'll resolve things along with linux kernel 5.0 in Ubuntu 19.04.

    In Windows, I'm experience 6-8 hours battery life just browsing and light work. I ended up just using VMWare (you can get a pro license pretty cheap on ebay) in Windows to get a linux environment for my development work. It works decently for now, but I prefer the non-virtualized environment.

    You can try RMAing and seeing if a different unit has better results. I RMA'd and still got the same results with Ubuntu.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >