Blade Pro coil whine and SD card problem- should I get a replacement?

Discussion in 'Systems' started by PRIMEcai, Jun 2, 2017.

Thread Status:
Not open for further replies.
  1. PRIMEcai

    PRIMEcai New Member

    I've had the Blade Pro for about 72 hours and have tested it extensively for any problems.
    1. There's this really really faint coil whine when I lean insanely close to the the area above the CPU and GPU. It's fairly silent and tolerable right now but I'm not sure if it will get louder in the future.
    2. The SD card reader doesn't read my SD card. I've went into device manager and there was no SD memory device so I can't update the driver. I contacted Razer and they basically told me to do a full system recovery (which to me seems sort of unnecessary).

    So with these problems, should I contact Microsoft (ordered from MS Store) for a replacement or is the coil whine inevitable and should just stick with the one I have now?
     
  2. bricktator

    bricktator New Member

    Ok, firstly do you push the pro to the extreme or no?
    Secondly you will need to either need to download an sd card reader or do the system recovery

    If you need any more help don't hesitate to ask me. (I open and fix a lot of thing.) :stuck_out_tongue_winking_eye:
     
    PRIMEcai likes this.
  3. PRIMEcai

    PRIMEcai New Member

    I noticed the coil whine when I booted up the laptop for the first time. I've only run Unigine and CPU benchmarks so far but my temps don't go past 85.
    Also, what sd card reader do you recommend?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >