Blade Stealth 2016 Linux not Booting

Discussion in 'The Linux Corner' started by Mark_OS, Jun 11, 2019.

  1. Mark_OS

    Mark_OS New Member

    Hi together,

    I own a Razer Blade Stealth 12,5" from 2016 (RZ09-01962G11). I am trying to get used to Linux because I recently got a new project without knowing anything about Linux and I want to be able to learn/try wherever I am. That´s why I am trying to install/boot it on the blade. Now my problem:

    I "burned" an iso of Linux CNC on a USB-stick using Rufus. I disabled secure boot and fast boot and tried to boot from the stick. But if I press enter to boot from the stick nothing happens. So I read something about UEFI and legacy so I changed that in bios, too. Now I got my internal drive and the stick twice. One of them does the same thing. The other one "boots" but after pressing enter I only get a Black screen with what looks like a graphics card or display problem. Its static stripes from left to right in pinks and green mostly. Changing form UEFI and legacy or whatever its called to just legacy made that stop but now I only get a black screen where I can´t do anything.

    Updated BIOS to 8. something, tried several USB sticks (they work on my computer and boot Linux correctly), tried several Linux version, tried NTFS and FAT32 format of sticks, tried external display, tried Lili USB creator, tried several bios options,...

    I have no idea what to do else cause I have no idea how such things work and I tried all I have found on the internet so far.

    Any hint, idea, any help?

    Markos
     
  2. Mark_OS

    Mark_OS New Member

    Thank You. That worked!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >