Blade Stealth (Late 2019 GTX - 10th Gen Intel) + Core X Chroma

Discussion in 'Razer Support' started by StinkerMago0, Nov 19, 2019.

Thread Status:
Not open for further replies.
  1. StinkerMago0

    StinkerMago0 New Member

    Greetings,

    I recently purchased a Blade Stealth Late 2019 GTX with has the Intel 10th Gen (1065g7) CPU. This is to replace my original Stealth 6500U model which I have been using with my Core X Chroma with little to no issue.

    Unfortunately when I plugged into my Core nothing is recognized. I get a new 'device' in device manager called a PCI Express Upstream Switch Port which states "this device is not working properly because Windows cannot load the driver required for this device (code 31)"

    I have tried upgrading the thunderbolt drivers, even tried to use my old Core V1. Same results.

    I upgraded to the latest version of Windows 10 (1909) which did not resolve the issue. I rolled the whole thing back using the recovery option. Still nothing.

    Anyone out there successfully connected these two devices? I do have a ticket in with Support but was hoping to find some additional resources here.

    Thanks!
     
  2. StinkerMago0

    StinkerMago0 New Member

    Seems I was able to resolve this by force feeding the machine the latest nVidia drivers. Note I had to use the DCH vs the WHQL driver. After which it seemed to take off just like I had expected.

    In the past I have had to wait until after the core was recognized as the nVidia driver would not install without detecting a valid card. In this case it was opposite of what I have experienced.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >