Bought new Orbweaver, can't get Synapse to work.

Discussion in 'Razer Support' started by retroPaleSpringBud587, Sep 10, 2018.

Thread Status:
Not open for further replies.
  1. I just received a new Orbweaver Chroma to replace my ailing Nostromo, I love the feel of it and it seems great so far, but I've wasted the whole day trying to get Synapse working with no luck.

    First I downloaded Synapse 3, then was surprised to see that the Orbweaver wasn't supported. Seems weird to me that the flagship keypad isn't supported, but whatever.

    So I downloaded Synapse 2, and while installing it I had problems with signed driver warnings. I managed to get around that by disabling driver signing on my system, did a fresh install, then it worked...for about ten minutes.

    In the time it takes me to open the software and start changing the maps and lighting, the LEDs on the Orbweaver will reset themselves to the default and any changes will stop registering. Then if I close the program and try to open it again, the tray icon will appear but I can't click on it in any way. Synapse 2 is running, as are all of the other components like the Chroma SDK service, but I can't open or interact with them in any way.

    I've uninstalled and reinstalled it several times now and the result is always the same. I'm very disappointed to say the least, especially considering that I also bought a Roccat mouse and a Cooler Master keyboard which both work perfectly.

    Is there any known fix for this? I've been reading threads on various websites trying to find a solution, some of which are as much as three years old, which is quite worrying.

    And now it isn't even detecting the Orbweaver...

    Attached Files:

    Last edited by a moderator: Oct 17, 2018
    LeMinh97 and pancholr like this.
  2. jodypeck

    jodypeck New Member

    Same here. i have a glowing paperweight now. i have done everything suggested online. pretty disappointed again with Razer. i have a deathstalker keyboard that isn't fully functional also.
    LeMinh97 likes this.
  3. wardog_33

    wardog_33 New Member

    I too just purchased the Orbweaver. Soooo excited to get it home and pitch my Nostromo n52.

    Downloaded the Synapse 3.0 and same thing... no support and can't recognize my device. After many forums I was led to download and install the Synapse 2.0 software. Many people complain that Synapse isn't compatible with Windows 10 and having trouble installing it. I, however had no issues installing the Synapse 2.0 AND it does see my device. I have it all set up with my macros and lighting I desire.

    My advice would be to give the Synapse 2.0 a shot. In my humble opinion, I really like the 2.0 over the 3.0 because it feels like the software I used to use on the Nostromo.
  4. Hi Wardog,
    I'm using Windows 7 x64, and I am indeed using Synapse 2. Synapse 3 is not an option for Orbweaver users right now because the product isn't supported. Synapse 2 is the program that is giving me problems.

    Right now my solution has been to simply disable all of the Razer software and use the Orbweaver as a standard HID device with the default key layout. It means I can't change the key maps or the lighting, or use any profiles or any advanced functions whatsoever, but it does at least have the most basic functionality of registering key presses.
    Note that you may have to go into the device manager and disable a device that shows up in the keyboard list as a HID compatible game controller, otherwise the thumb stick will mess up your keybinds in games when you try to remap them.

    Obviously this is a far from desirable solution as it has none of the advertised functionality whatsoever, but at least I can play my games (albeit I have to remap everything in those games).
    Last edited by a moderator: Oct 17, 2018
  5. wardog_33

    wardog_33 New Member

    Hey retro, sorry you are having issues. Not sure why Synapse 2.0 wont work with Win 7 x64. I'm running Win 10 x64 and at least allows me to use the software and the device.
  6. FirePenguin

    FirePenguin Retired


    To the people who are having problems, I sent you all PM's. Please give me a reply so we can look into this.
  7. wardog_33

    wardog_33 New Member

    Ok, so I went ahead and purchased a Razer Naga Trinity mouse (which only works with Synapse 3.0) and I also have the Razer Orbweaver (which only works with Synapse 2.0) and here's what I can tell you... You can run both the Synapse 2.0 and 3.0 side by side. Should we have to do this because the Orbweaver is not detected or backward compatible with Synapse 3? No, BUT where there is a will there is a way and I have both devices up and running side by side.
  8. I'm currently in contact with Razer customer support via email, so if I find a solution that works for me I'll post it in this thread. No luck so far unfortunately.
  9. csills89

    csills89 New Member

    Is anyone getting a mscorlib.dll error? If so I have the same Issue!
  10. darkenergymedia

    darkenergymedia New Member

    curious what you guys have to look into here. the orbweaver isn't supported. synapse 2 doesn't work in a serious way anymore. it's pretty cut and dry.

    the problem is, i'd guess, that people like me are tired of waiting and hearing excuses. my disdain for razer increases with every new RAZERphone announcement i see while my day-to-day products i've purchased from you sit idle on my desk because they don't work.

    not only that, but it's not addressed.

    the core software that powers and configures all of the products you sell is in an eternal BETA state with no solid roadmap of when it will actually be a reliable, solid solution.

    i'm happy to PM with you if you think it's going to help, but that's pretty much the gist. and for what it's worth, i'm looking actively into other solutions for the future, as RAZER has simply failed to do the bare minimum here, in my opinion.
  11. Just an update.
    Things are proceeding quite slowly and we're still doing very basic troubleshooting (like them asking me to test it on other computers), I have no progress to report unfortunately.
    Besides the software being completely non-functional I am enjoying using the device and I think it's great. Just wish that y'know...the software worked.
  12. Deemo

    Deemo New Member

    I too just purchased an orbweaver and have tried all basic troubleshooting steps such as installing and reinstalling Synapse, updating all my computer drivers, and making sure all my USBs are working. Kinda sucks that I cant map the keys on this thing!
  13. treymac111

    treymac111 New Member

    I cannot get synapse to work correctly with windows 10 either.
  14. I'm not sure what to do next, support wants me to test the Orbweaver on another computer, which for one I don't believe is necessary as there is no hardware problem and it wouldn't help to diagnose a software problem that's specific to my PC. It's also impossible because I don't have access to any other computers right now.
    So apparently I can't get any support beyond this point?
    I kind of feel like they're just stalling for time so that I can't return it to Amazon at this point, which I wasn't going to do anyway...
  15. Ok so I was finally able to get through to one of the guys from the software department, and with his help I believe we were able to solve the issue.
    Get ready for a long post because I'm just going to dump all of the info in here. I believe step 3 is where the problem resides, but I'll include everything that we did for completeness.

    The first step was some basic updating and system repair stuff. I was asked to run sfc/scannow in order to repair any damaged windows system files, and the scan found a couple which it repaired, here's how you do that:
    1. Press Windows + r and type in "cmd" without quotes.
    2. Right click on cmd and run as admin.
    3. Type in sfc /scannow and wait for it to finish.
    4. Restart the computer.

    Step two was updating the Microsoft .NET framework to at least version 4.5. I'm pretty sure that I already had that installed but I downloaded and updated to version 4.7.2 anyway.
    You can download the latest installer from the Microsoft website here:
    I was told that I needed to enable it through the Windows Features menu, but that does not seem to be necessary for this version of the software, at least on Windows 7.

    Step three is where it gets interesting.
    So I was asked to repair or install Microsoft Visual C++ 2015 redist. When I went to check if it was installed via the programs list under the control panel, it wasn't. I had everything from VC2005 to VC2013, and then VC2017, but no VC2015. When I downloaded and tried to install it however, it told me that it was already installed. Confused, I spent some time searching around various forums, and what I discovered is that VC2017 actually contains all of the runtimes and software from VC2015. If your computer is properly updated then you shouldn't have VC2015 at all, it's obsolete, and is in fact incompatible with VC2017.
    The problem is that Synapse 2.0 searches for the VC2015 redist when it installs, and without it you'll get a driver signing error. If you then disable driver signing and allow it to install as I did, it will go haywire and start freezing/crashing.
    So to get around this, what I had to do was uninstall VC2017, then install VC2015, install Synapse, reboot, and then reinstall VC2017 again. The VC2015 redist needs to be present for Synapse 2.0 to install and work properly, because it doesn't seem able to use the runtimes and software from VC2017, despite the fact that everything from VC2015 is contained therein.

    So in summary, I believe the issue is caused by Synapse 2.0 searching for an obsolete Visual C++ redistributable. Here are the steps to fix it for convenience:

    1. Go to Control Panel > Uninstall a Program and remove the two entries for Microsoft Visual C++ 2017 Redist.
    2. Download the Microsoft Visual C++ 2015 Redist from here: then install both the x86 and x64 versions.
    3. Install Synapse 2.0 and let it update (make sure to remove any residual files and folders relating to Razer and Synapse before doing this to make sure it's a clean install).
    4. Reboot your computer.
    5. Download the Microsoft Visual C++ 2017 Redist from here: then install both the x86 and x64 versions and reboot.

    Once this is done, you should have VC2017 installed and up to date, and VC2015 will no longer be present on your computer, but Synapse 2.0 should be properly installed and working correctly. I now have access to all of the features like the macros and lighting for my Orbweaver and the software hasn't been freezing or failing to open anymore. I've been using it all day, and after several reboots it seems to be behaving itself.

    Considering that so many people have been having this issue (and going back several years if threads on other websites are anything to go by) I really feel like Razer's software team needs to look into this and fix it. I realize that development on Synapse 3.0 is a priority, but support for devices is spotty and Synapse 2.0 is still very much necessary and will be for the foreseeable future. I don't imagine than telling Synapse 2.0 to look in the VC2017 directory for the files that it needs instead of in the VC2015 directory is much of a problem, albeit I am not a programmer.

    Anyway I hope this post helps anyone else out there who might be having this issue. I am currently enjoying an Orbweaver with working software that is finally the same damned color as my keyboard and mouse, and I am very happy.
    felthas1650 likes this.
  16. felthas1650

    felthas1650 New Member

    I spent a lot of time dealing with issues. This was one of them I never got a clear answer on but a buddy helped me solve. Nice that you put it here in detail so others can fix it.

    They seriously need to get all the older devices pumped over before they crank out new keyboards and stuff. I purchased my orbweaver thinking since it was a relative new release it would work with whatever I had and well I was wrong. However I LOVE all my gear. Hate that I have to run 2.0 and 3.0 at the same time though.
    retroPaleSpringBud587 likes this.
  17. As far as I was able to tell, this particular problem goes back at least three years, I was able to find threads referencing it that were at least that old. Support was a big help and pointed me in the right direction, but ultimately I had to figure this out for myself. I have now given them all of the information that they need to fix the issue, I sent it to the support rep via email, I posted it here, I sent a PM to a moderator and I included it in my feedback form. This should be a pretty simple fix, so if the problem persists after the next Synapse 2.0 update I'm going to be pretty angry with them, because there's no excuse at this point, I've done 95% of the work for them.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >