Brand new Black Widow v3 Pro Wireless some keys don't work

Discussion in 'Razer Support' started by evergardenCanary508, Feb 18, 2022.

Thread Status:
Not open for further replies.
  1. evergardenCanary508

    evergardenCanary508 New Member

    Hi,

    My brand new Black Widow v3 Pro Wireless arrived this morning and the U, J, 7 and numpad 6 keys don't work (there may be more, those are the ones I've noticed so far).

    The issue happens both via USB, wireless and bluetooth.
    Windows 11 is up to date.
    I've updated keyboard and dongle firmware.
    I've done a clean install of Razer Synapse as per https://mysupport.razer.com/app/ans...tallation-of-razer-synapse-3-&-2.0-on-windows
    I have done a factory reset of the keyboard via Synapse.
    I have tried a different USB cable.
    I have tried having ONLY the Black Widow v3 Pro and my Naga Pro plugged into USB literally nothing else.
    I have held down the Esc, capslock, space bar and turned on the keyboard to reset it as per https://mysupport.razer.com/app/ans...-keyboard-with-a-hard-reset-or-by-exiting-out
    I have tried setting my windows language to US English and restarting, this didn't help.
    I have tried multiple restarts.
    The issue still happens on a different PC running Windows 10 via USB with a clean install of Razer Synapse.
    All USB ports used were plugged directly into the back of the PC and were USB 3.0 or better.

    Also when I restart the PC OR after unplugging the keyboard and plugging back in / turning on wireless mode it permanently spams UJ7 (or some other combination of the faulty keys) over and over until I press a bunch of buttons on the keyboard.

    I'm in New Zealand and bought the keyboard online from Australia at https://www.mwave.com.au/

    It looks like this keyboard is faulty on arrival to me (I'm a computer technician with 15 years experience) however I'd much prefer to be told how to fix this rather than needing to pay international shipping to have it replaced or returned.

    Quite gutted to be honest as this keyboard was extremely expensive, especially for this experience.

    This isn't the first time I've had issues out of box with Razer products, so to say I'm disappointed is an understatement.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I saw your PM and decided to reply here first. Thanks for narrowing down the issue and attempting to resolve it. It seems like the keyboard has a potential hardware issue since the behavior continues while plugged into another computer. Should the spamming happen, or the device not respond after disabling/closing the Razer Synapse 3.0, please contact your reseller and request a warranty claim since that is the fastest route to get a replacement. Feel free to send me a ping should you need additional assistance.

    *Thread is now locked.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >