Brand new out of the box Razer Kraken Kitty connecting and disconnecting

Discussion in 'Razer Support' started by acedevil43, Aug 12, 2021.

Thread Status:
Not open for further replies.
  1. acedevil43

    acedevil43 New Member

    Hi all,

    I'm facing an immense amount of frustration dealing with the Razer Kraken Kitty.

    Out of the box, i plugged the device into my PC, and the device kept connecting and disconnecting. Sometimes it refuses to connect at all.

    I explored all options available on this site. The razer FAQ was incredibly unhelpful. Forumers suggested uninstalling synapse 3 which i did. Some suggested a reinstall of .NET Framework, updating drivers. I disabled drivers one by one from device manager simply trying to narrow down the issues. I did them all. I'm currently connecting with the Razer dealer in Japan (where i am based and purchased the device) and am looking at options to obtain a new device.

    I spent 6 hours last night trying to figure out the problem and how to resolve the issue - seriously Razer, it really shouldn't be this hard to enjoy your products. But i think i finally narrowed down the issue.

    The connection issue disappears entirely when i removed the RGB CHROMA component of the driver from the Windows 10 Settings section. Effectively, this allows me to use the MIC and Headphone, but i lose the ability to use the RGB component of the Device - WHICH WAS THE REASON WHY I SPENT 20,000 yen ON THE THING.

    In short - there's a software / driver issue here. Because the damn thing lights up no problem, before it disconnects and reconnects again. But i'm almost certain that the RGB chroma driver is in conflict with some USB related driver.

    Perhaps someone can help me here, but short of replacing it with another Razer Kraken Kitty, I'm not able to return this, nor am I able to get a refund.
     
    FoxenBoxen likes this.
  2. I have the exact same issue! My headset works fine on my laptop, so I wonder if maybe it's not the device itself? I also reinstalled synapse, went through all the driver updates and reinstalls etc/tried everything I could find online and so far nothing.
     
    nlk8690 and FoxenBoxen like this.
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi acedevil43. Have you checked if the behavior happens when the headset is connected to another USB port or computer? Also, please check if running your Windows troubleshooter could detect any hardware issue in your unit. Feel free to send me a PM, including MSinfo and Synapse logs. Save the compressed files via Google Drive or any online drive account, then paste the link in your PM. I'll be locking this thread to curb our conversation privately.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >