Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Brand New Razer Blade

Discussion in 'Systems' started by Sous0u, Dec 9, 2016.

Thread Status:
Not open for further replies.
  1. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    Hi Guys,

    I need your help.

    I received my RB 2 days ago all was perfect so far, then yesterday I installed the lastest Nvidia driver with using DDU, once I did it I couldnt adjust the brightness of the screen, then I tried to rollback still couldnt adjust anything and I spotted my nvidia control panel was totally empty, I only could managed 3D settings.

    So i decided to re-installed windows from scratch, then I could adjust the brightness but my Nvidia Control was still empty. I also noticed my battery didnt tell me how many minutes left I have. To be honest I like the RB but for a BRAND new computer its a bit annoying to already have issue after just a driver install.

    Any helps guys?

    Thanks
     

    Attached Files:

    Last edited: Dec 9, 2016
  2. geoPaleRobinEggBlue893

    geoPaleRobinEggBlue893 Active Member

    What exactly is DDU?
    You downloaded official drivers from Nvidia for your card yes?
     
  3. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    DDU: display driver unistall

    And yes its from a nvidia site & when I rollback it was Nvidia driver from razer support.
     
  4. geoPaleRobinEggBlue893

    geoPaleRobinEggBlue893 Active Member

    I'm a bit confused. Did you use DDU to install a driver or uninstall like its name suggests?
    Just go to Nvidia's site and download drivers for your graphics card. It's the gtx 1060 yes?
     
  5. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    sorry let me explain, to do a clean install I used DDU to unistall all Nvidia drivers in safe mode. when I re-installed the nvidia driver downloaded from nvidia.com this is when my issue arrived. I read it an issue regarding also the Intel HD graphics but couldnt find a solution yet.
     
  6. geoPaleRobinEggBlue893

    geoPaleRobinEggBlue893 Active Member

    Could be an issue with the driver installation or the hardware itself.
    I suggest you try reinstalling the drivers for your gfx card. If that doesn't work, might be time to see what Razer support has to say about it.
     
  7. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    I re-installed everything 3-4 times already. and this scenario is from a FRECH W10 install. the Razerblade is a brand new one.
     
  8. geoPaleRobinEggBlue893

    geoPaleRobinEggBlue893 Active Member

    Definitely try hitting up Razer support. Might need to be sent in for repairs.
    Let us know what happens. Gl!
     
  9. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    they told me: try to recovery,

    I gonna ask for a refund and bye bye razer. that so fucking pissed me off to be honest.
     
  10. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    ok guys when I came back home for lunch all was OK, I plugged the my monitor in HDMI and check control panel was working fine.

    All good.

    Only things missing now is the battery calculation.

    Looks like its not working.
     
  11. geoPaleRobinEggBlue893

    geoPaleRobinEggBlue893 Active Member

    That's great to hear!
    About the battery issue, Windows 10 has a built-in troubleshooter you can use.
    To access it
    1. Press Windows key +X, select Control panel.
    2. Change the view by option on the top right to Large icons.
    3. Click on troubleshooting and click on the view all option on the left panel.
    4. Run the Power troubleshooter.
    Let us know it goes.
     
  12. TheGurgeMan7

    TheGurgeMan7 Well-Known Member

    The battery calculation is a windows 10 glitch. Its not anything to do with razer.
     
  13. aab010799

    aab010799 Active Member

    This. I get the same thing occasionally but then other times it works.

    Also, I wouldn't really blame Razer for your problem OP. Why did you want to DDU in the first place?
     
  14. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    Ok I will tried that @Huz, thanks for all you anwsers.

    About DDU it was my nvidia graphics but not its all sorted, after a fresh w10 install & a clean install of all GPu + a reboot.

    I dont have any issue so far I will make few test @ firestrike without/with overclocking and SDD writing speed I keep you update.

    For the Battery doesnt matter, But yesterday I installed & unistalled many software with full brightness (as it was locked) + surfing and downloading stuff, running 3d Benchmark during 3Hish on battery. looks good for my point of view
     
  15. CobaltBluegreatx378

    CobaltBluegreatx378 New Member

    Morning Guys,

    so I ran few benchmarks over the weekend.

    Out of the Box EC4.0 my Firestrike score was: 9300
    With few overcloaking I manage to have 9700.

    Quite happy so far to be honest :)

    I love this PC the only thing is fingermagnets but I gonna order dbrand asap.
     
  16. realsmurf

    realsmurf Member

    i have the same glitch, no time remaining shown anymore, anyone knows how to resolve this? windows trouble shoot didnt work for me
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >