Bumblebee on the Blade (2018 version)?

Discussion in 'The Linux Corner' started by bitGoldenPoppywatch897, Nov 29, 2018.

Thread Status:
Not open for further replies.
  1. Has anyone of you managed to get Bumblebee to work on the Blade 2018?

    I'm running Fedora 29 with KDE and I have trouble getting Bumblebee and Nvidia's proprietary drivers to work. I've followed these instructions, but every time I try to run a program with optirun, I get an error message.

    At first I got this error:
    Code:
    $ optirun phoronix-test-suite shell
    [  164.635877] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
    
    [  164.635903] [ERROR]Aborting because fallback start is disabled.
    Then I added this kernel parameter: nouveau.modeset=0
    And now I get the following error:
    Code:
    $ optirun phoronix-test-suite shell
    [  244.441784] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
    
    [  244.441879] [ERROR]Aborting because fallback start is disabled.
    
    I then added these kernel parameters: acpi_osi=! acpi_osi='Windows 2009'
    As suggested here because the Blade has an American Megatrend BIOS.
    But then the touchpad doesn't work and I still get the same error... so I reverted the change. These parameters were supposed to fix a different problem anyway if you read the link...

    I'm not sure, but maybe the problem is related to Wayland.
    Or maybe the instructions to install Bumblebee didn't install the Nvidia proprietary driver correctly.
    When I run: cat /proc/driver/nvidia/version
    I get: "cat: /proc/driver/nvidia/version: No such file or directory"
    which kinda suggests that the Nvidia driver is not there.

    I'm running out of ideas. Any help is greatly appreciated!
     
  2. Well, this probably isn't much help to you but for what it's worth, I had a 2017 blade running manjaro with bumblebee. I just went to the manjaro settings manager and clicked the bumblebee radio button and installed and it worked out of the box, no hassle.
     
  3. It appears to be a problem with KDE. Using Gnome it works without a problem.
     
  4. Interesting.. And disappointing. I'd been looking to switch from Gnome to KDE. On a related note, I've had pretty bad screen tearing on mine (using gnome as well), have you experienced this?
     
  5. On Gnome I haven't had any tearing issues.
    On KDE it was either tearing (V-Sync off) or stutter (V-Sync on). But honestly that could have easily been because the driver wasn't installed properly.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >