Can Not Change Settings for Keyboard in Synapse 2.0

Discussion in 'Razer Support' started by thehwood, Feb 22, 2021.

?

Is Razer Synapse detecting your devices correctly?

  1. Yes

    0 vote(s)
    0.0%
  2. No

    100.0%
Thread Status:
Not open for further replies.
  1. thehwood

    thehwood New Member

    Hello,
    It seems a lot of people are having trouble with Synapse detecting devices, myself included. I believe I have tried all of the troubleshooting without any luck. I have performed a clean install of Synapse 2.0 and 3, manually deleted drivers in device manager, tried different USB ports, disabled anti-virus, etc.
    Synapse will only allow the settings for my mouse to be changed (Razer Ouroboros).
    The drivers are being downloaded for my keyboard (BlackWidow Ultimate Stealth 2016 Edition), but beyond that, am unable to see or change any settings for the keyboard. I kind of think it's a UI issue for the program.

    I have been a big Razer supporter for a long time and I'm about to the point where I'm ready to switch brands.
    The amount of unanswered posts and people struggling with these issues is really disappointing.

    I realize the keyboard is nearing 5 years old, but there is nothing wrong with it. I am not afraid of buying a new one, but I assure you it will not be a Razer...

    If there's another troubleshooting tip I have missed, I would love to hear it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >