Can't acces Synapse server

Discussion in 'Razer Synapse 3 Beta' started by Gazaipe, Apr 20, 2019.

  1. Gazaipe

    Gazaipe New Member

    Hi !
    First of all , English is not my first language , so i'm sorry for you'r eyes .
    So here's the problem : i just got my self a razer naga Trinity , and i saw that i needed Razer Synapse too use it properly . i tried too install it , but i get the same message everytime when i try it : "server access impossible"
    Can some one help me ? :big_grin_:

    ( i tried Razer Synapse 3 because the manual told me too )
     
  2. MagusRazer

    MagusRazer New Member

    I also always get server error when installing synapse. It happens around 50-60% during the installation. Clicking retry on the pop up does help though for it to continue.
     
  3. Gazaipe

    Gazaipe New Member

    I've tried it for one hour now , still not working :c
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    Yep this bug i write some time ago but still not fixefd.

    Delete everything from razer apps/files etc. cheack if you have files in programfiles and appdata folders if you have remove them. When everything will be removed download new installer from razer website and disable firewall and antivus softwere thay might block sometime connection. Click right mouse buton on synapse 3 installer and select "Run as Administrator" synapse installer will run when synapse 3 will download on some point you will get error then click just retry and install will continue.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >