Can't change DPI on Reazer Deathadder elite

Discussion in 'Razer Support' started by 91xoL, Jun 17, 2021.

Thread Status:
Not open for further replies.
  1. 91xoL

    91xoL Active Member

    Hello everyone,
    I have a problem with my mouse, I can't change the DPI sensitivity.
    The buttons works all fine and I can see on Synapse 3 that they change the settings, but in reality it doesn't work.
    I tried to uninstall and reinstall synapse 3 with no results, I even try to update the firmware (version 1.06) of the mouse with the dedicated link I found (firmware), but even if I close all synapse programs (I even tried with it uninstalled) it doesn't update the drive and remain on version 1.02.1.

    My mouse isn't in warranty anymore, so I can't ask for technical support from the razer staff and the only way is via the forum.

    I think that could be a cloud problem, with the data corrupted in the cloud, I don't found any way to go offline on synapse 3 or remove all cloud's data.

    Someone can help me with this problem?

    1.01 EDIT : I tried to install synapse 2 but the issue still remain, I even try to update the driver to version 1.05 but it gave me the error --> "parameter cannot be null. Parameter name: value"

    1.02 EDIT : I tried from another PC that never got this mouse plugged in, there are still the same issue with the firmware update, I even tried to log into synapse3 as a guest from this PC, but still the DPI remain locked only on one sensitivity and change it does nothing.

    1.03 EDIT : I follow this guide on the forum for a clean reinstallation and the "manual change of DPI", still doesn't work even in guest mode https://insider.razer.com/index.php...i-options-and-the-lighting.74869/#post-757531

    1.04 EDIT : Every system in my computer is updated, from win10 to nvidia drivers.
    I don't think is a cloud issue because even in guest mode it doesn't work properly.

    The problem appeared when I turned on the PC, the day before was all working fine.
    The mouse is still in good conditions, it doesn't have any hardware damage.
    I sincerely hope that there is a software solution to this problem, I don't want to create unecessary e-waste just because the mouse decide to set itself in default conditions and doesn't comunicate with synapse3.

    1.05 EDIT : I restored the driver of the mouse and now I can change between the default sensitivity using the assigned buttons but only if synapse3 is closed (if I open it it stops on a default DPI in every config, even if the settings are 100/800/.....).
    Still I can't update the firmware, this time it doesn't even start the download, it stops after a couple of minute with the message: "Please reconnect your device!", ofc I don't plug it off during the process...
     
    Last edited: Jun 18, 2021
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hey @91xoL! I responded to the PM you sent. Please check your inbox.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >