Can't link Razer and MOL

Discussion in 'Razer Support' started by ThatZeta, Nov 29, 2018.

Thread Status:
Not open for further replies.
  1. ThatZeta

    ThatZeta New Member

    [PROBLEM WAS SOLVED BY TRYING TO DO IT ON MOBILE.]

    Hey Razer-Forum,

    I'm running into a weird problem. I got the eMail earlier about the new Razer Gold thing coming. So I got myself a MOL account and I'm trying to link it to my Razer account. It redirects me to Razer, I insert my data and it redirects me to MOL, but then I'm stuck in an endless loop of this:

    [​IMG]

    I've tried switching off add-ons that could potentially block the page, I've tried using a private window so there would be no add-ons loading from the get go and I even tried using another browser, but it doesn't work. I'm still stuck in this loop.

    Any ideas?

    Edit: I would like to add that I cannot do it on mobile phone either. I'm still stuck in the "Loading..." loop, even on mobile, so it's not a computer setting that's the issue.

    Edit²: disabling the shield-function of the Brave-Mobile Browser allowed the page to load. If anyone is having the same issue and stumbles over this thread, it appears to be something blocking the script. Maybe even an anti-virus program. Probably helps to disable it for five minutes and try disabling any ad and script blocker that's on the browser. Or if all else fails trying a new browser profile where no ad-ons are installed.
     
    Last edited: Nov 29, 2018
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >