Can't register new mouse

Discussion in 'Razer Support' started by royhale3, Jan 29, 2021.

  1. royhale3

    royhale3 New Member

    I just got my Razer Basilisk and wanted to register it and was following the prompts for s/n and p/n but the product and serial numbers don't match it says. I noticed that on the display prompt for the product number the first 2 digits are "RZ" but the ACTUAL product number begins with "RC."
    I hope I explained everything clearly enough to present the issue.
    A prompt response would be appreciated as I would really like to register my new mouse
    Thank you
     
    nplas likes this.
  2. Orion7412

    Orion7412 New Member

    This is also happening to me
     
  3. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

  4. nplas

    nplas New Member

    I have tried doing this online and through synapse and am also having the same issue
     
  5. Jaroob

    Jaroob New Member

    It is more than likely the product number that is causing the issue. You will have to look at the product number on the box that your product came in and not the product number on the device itself. There will more than likely be more than one product number on the box, but you will want to use the one that starts with the letters "RZ" and not "RC". This is what solved my issue. I was able to successfully register my product after that.
     
    Mixologist23 likes this.
  6. Mixologist23

    Mixologist23 New Member

    @Jaroob is correct. I was having the same issue with my wolverine ultimate Xbox controller. The product number on the controller was showing up incorrect. The correct numbers are on the box that your device came in
     
  7. its probably you bought your product that isn't original that's why it can't be registered it's happening to me too and I'm pretty annoyed by it because all I wanted to do was to adjust my dpi and couldn't because of this
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >