Can't turn "on" Chroma Apps Synapse 2

Discussion in 'Razer Synapse' started by xangbar1297, Dec 16, 2018.

Thread Status:
Not open for further replies.
  1. xangbar1297

    xangbar1297 New Member

    The title says it all. I have been un-installing and re-installing Synapse 2 (and 3) all day with no progress. My Chroma lighting effects for Diablo III, World of Warcraft, and Overwatch have all ceased working. Originally, my lighting effects would just freeze and get locked up so I un-installed all the Razer apps I had and then re-installed just Synapse 2 since that one was working fine in the past. However, I also un-installed the Chroma SDK software that I had installed as a stand-alone. I know this is packaged in to the newer versions of Synapse 2 and 3 but it doesn't seem to work. In Synapse 2, when I click the "on" button, it switches to on. However, if I go to another page, it switches back to "off". This is causing my Chroma effects to no longer work. Is there anything that could be done to fix this? I have Synapse and Chroma installed on my laptop as well and it works perfectly fine but my gaming desktop is the one with the issues.
     
    Liveyevil and 0V3R_K1LL like this.
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Try to Remove all razer softwere from pc then go to device menager and remove every razer device you have unplug them and reboot pc plug devices when windows start and install again synapse. Cheack if this help.
     
  3. MixxiD

    MixxiD New Member

    I am having the same issue here, I have my Blackwidow X Chroma since july 2018 but it has only worked for 2 days and that was it. And when I tried the same with Synapse3, (I alwas had ,,Chroma Apps`` ON) not a single game was recognised, nor could I get the look for a specific file tool started.
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    In synapse 2 you dont have keys to turn on or off becose this is build in app on synapse 3 there is way to cheack so first cheack if the game you are playing is on razer compatibility chroma games if yes go to synapse 3 chroma tab and select app select game from the list and cheack if toggle is in on mode.
     
  5. MixxiD

    MixxiD New Member

    That exactly is where it fails, the games never show up
     
  6. BlackFireDragon

    BlackFireDragon Well-Known Member

    Like i write above chroma apps and pre-build profiles dont show on synapse 2 you can tern on/off via toggle this feture and this is it on synapse 3 every chroma app and game that have pre-build profile will apear if it's supported. The best way is that to cheack the game on razer workshop chroma supported games or write here what app or game have the issue becose it hard to recomend solution when you dont have idea what exactly you are using :stuck_out_tongue_winking_eye:
     
  7. MixxiD

    MixxiD New Member

    Im sorry I was so unprecise. What i am currently trying to do, is play Overwatch with my Blackwidow overwatch edition and my Deathadder overwatch elite. Now, in the beginning I had Synapse 2, the Synapse 3... both worked perfectly intil one day they stopped working- for all games. On Synapse 3 no games were detected. The problem with Synapse 2 was that the button to toggle chroma apps always goes to ´´ OFF´´ . So if I toggle it and then go to another page and then come back, its on the OFF position again. I lokked for a fix and I found something that worked with deinstalling the core components and intalling older ones, but unfortunately I cant find any core components folder or Icon like shown in the fix tutorial. it didnt matter how many times reinstalled Synapse3. I have only found a chroma sdk components folder. Though when I delete it, it says that it is faulty, and tha t it cannot remove it properly- it´ll only delete it from the programs and features list. Upon trying to install the downloaded core components, a window flashes up and goes away after a millisecond- nothing happens. Ill link you the fix tutorial so that you know what I am talking about. If you have any questions ask me, I would really love to see my keyboard work again.

    https://insider.razer.com/index.php?threads/overwatch-chroma-fixed-june-28.23796/page-5

     
    Liveyevil likes this.
  8. Liveyevil

    Liveyevil New Member

    I am having this exact behavior. Precisely the exact same steps. I noticed that I get the SDK installer Flash too but I think this is due to it being a registered/installed application, when I go to add/remove it's appearing. If you uninstall it at that point then run the installer it will go but alas this doesnt seem to fix anything. I also noticed that the off/on issue in synapse 2 will occur if you do not have the SDK installed. With the SDK installed you should be able to toggled off/on however there are still no apps being detected. I have literally spent hours now fighting with this. I have sanitized all Razer files from my machine multiple times and re-i stalled both synapse 2 and 3. I will most likely attempt to invoke chat support.
     
  9. Liveyevil

    Liveyevil New Member

    I should add that I did very briefly get this to work by uninstalling everything, deleting all Razer directories and then re-installing synapse2/SDK however the behavior was very odd. I have read other forum posts describing this too.

    https://us.battle.net/forums/en/d3/topic/20752649160

    Basically when loading DiabloIII the lighting would be confused between my lighting settings and the diabloIII red (flashing back and fourth very quickly). I attempted to switch synapse profiles and since trying that it has reverted to not being able to detect any applications (DiabloIII) what so ever. I have also stopped/started/restarted the Razer SDK services in Windows.
     
    Last edited: Feb 12, 2019
  10. Liveyevil

    Liveyevil New Member

    UPDATE!

    After 8 hours of tireless trouble shooting including but not limited to system reformatting I have identified the issue. I worked with Razer online support who eventually escalated my request. As a last ditch effort hail-mary I unplugged my Corsair Scimitar mouse and ran DiabloIII with just my Razer keyboard plugged in. Low and behold the app was recognized. A quick google led me to this reddit post confirming that iCue does in fact conflict with Synapse: https://www.reddit.com/r/razer/comments/8vzzp8/razer_synapse_30_and_20_chroma_app_disabled_by/

    Great, now i have to unplug my mouse before launching Diablo... unacceptable ALAS I found another solution. In the Corsair iCue software settings there is an option to disable the "SDK". Un-check that box and problem solved. Case closed. This has been a trying and miserable exercise but we did it.
     
    Last edited: Feb 13, 2019
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >