Chroma SDK Problems

Discussion in 'Razer Chroma' started by XboxIssues, Apr 10, 2016.

Thread Status:
Not open for further replies.
  1. I know for a fact this problem originates from the SDK. Anyway, whenever I open the Chroma Visualizer, my keyboard goes black (sometimes flashes random colors when no sound is playing) and my computer no longer has any sound, if I go to the playback devices and right click on my astros and click "test" it says "failed to play test tone", then when I close the visualizer, my keyboard goes back to spectrum cycling, and sound returns, I had this problem when I first got my keyboard Monday, fixed it on the first day by installing the SDK Core 1.4.1, then the problem returned yesterday or the day before yesterday. I haven't installed anything new, changed anything, nothing, I make sure to close synapse before opening the visualizer, my synapse is up to date. I have no idea what the problem is.

    *EDIT* I forgot to add that at the bottom of the visualizer program there's a link to the creators github and it says "update to SDK 1.5.1, but I cannot find it. I don't know if that's the problem or if that's for different devices.
     
  2. njbmartin

    njbmartin Developer of Awesome

    This is not an SDK issue in the slightest. The SDK doesn't touch or go anywhere near your audio settings. If anything does, it would be the Visualiser app itself.

    The SDK is literally just for lighting up the keyboard. Please get in touch with the application's developer before posting your issue here. The developer is @CalcProgrammer1.
     
  3. voiceJaspersharp031

    voiceJaspersharp031 New Member

    I can confirm that the SDK was the reason it wasn't working. I was using 1.7.1 and only the keyboard was working but NOT my Naga Chroma. I uninstalled it and reinstalled the 1.4.1 version and is currently working beautifully.
     
  4. njbmartin

    njbmartin Developer of Awesome

    You should never install the SDK manually as there is no need. Just keep your Synapse up to date.

    There have been bugfixes released to the SDK core service which should fix those issues. As I have said above, you should not be installing older versions of the SDK. Please update to the latest version via Synapse and hopefully that will fix it.

    The SDK is now on 1.7.5.
     
  5. Zerogon

    Zerogon New Member

    I am trying to use the audio visualizer with my firefly and mamba TE, but i cant install the sdk to use it. The visualizer opens up and respondes to musica but my mouse and mouspad dont. I have been told to install sdk for chroma, but it tell me to run Enable SDK support.reg and i cant find this file. Can sometell me where this file is?(I dont know where in the docmentation folder it is)
     
  6. njbmartin

    njbmartin Developer of Awesome

    Keeping Synapse up-to-date will always install the latest version of the SDK. You appear to have stumbled on outdated instructions. I'd now advise uninstalling Synapse and the Razer Chroma SDK Core Components, and then reinstalling it fresh.
     
  7. Tereezy

    Tereezy Member

    uninstall and reinstall. I did that and the problem went away. Or go to update on your setting to latest version.
     
  8. Zerogon

    Zerogon New Member

    It still wont work. Just unistalled Synapse and Razer Chroma SDK Core Components and reinstalled and it still seems like my mouse and mouse pad wont responde to the audio visiualizer.

    PS: I use the GameDog app for Dota2 and it works fine with my mouse and mouse pad. Do i have to unistall it to use the Audio Visulizer(I didint have GameDog open when i tested the Audio Visualizer).
     
    Last edited: Jun 29, 2016
  9. njbmartin

    njbmartin Developer of Awesome

    If it works fine with GameDog, then the issue is in fact with the Visualiser itself and not the SDK.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >