Core X Chroma Ethernet dropping out on MacOS?

Discussion in 'Razer Support' started by MotoDC, Jul 22, 2019.

  1. MotoDC

    MotoDC New Member

    Hi Crew,

    Hoping someone else has come across something similar.

    Config:
    • New MBP 13" (2019) running 10.14.5, did not import previous system, just created a new account and went forward.
    • Core Chroma X (w/ Radeon RX 580 Saphire card)
    • Single USB C connection

    I've installed the Ethernet drivers from the Razer support site, but every 5-20 mins the ethernet connection drops. I can restore it by disconnecting/reconnecting the eGPU, or changing the physical NIC config from automatic to a set speed/direction, or back again.

    The frequency of the dropouts is getting annoying enough that the workaround isn't working any longer. In an attempt to address the issue I downloaded and installed a newer driver from the ASIX website here: https://www.asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112

    Unfortunately this also didn't solve the issue. I'm running off wireless right now, which works, but isn't optimal.

    Any suggestions on where I can look for hints as to the issue? I've checked out the console for logs, but don't see any messages that indicate anything with the NIC. Could it be the USB-C cable (not using the inbox one, but also not having graphics issues).

    Thanks in advance for any suggestions!

    Here is detail on the driver installed:
    Screen Shot 2019-07-22 at 8.56.56 PM.png
     
    Last edited by a moderator: Jul 22, 2019
  2. MotoDC

    MotoDC New Member

    Bumping this topic again to see any results. I've upgraded to 10.14.6, and the issue persists.
     
    Last edited: Aug 8, 2019
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for posting your concern here. Are you using a Thunderbolt 3 cable to connect your Macbook Pro to your Razer Core X Chroma? By the way, you cannot customize advance setting such as chroma lighting effect since Razer Synapse 3.0 is not yet compatible with macOS. If it is feasible, have you tested your Razer Core X Chroma to a different computer with either Windows or macOS that can suffice Razer Core X Chroma's requirements and see if the issue also persists?
     
    MotoDC likes this.
  4. barad

    barad New Member

    I've been suffering from the same issue on MacOs Mojave (10.14.6) with the latest AX88179 drivers (v2.14.0) on a 2018 MacBook pro. I'm using a thunderbolt 3 cable to connect. The GPU and other USB peripherals seem to be working fine, but the ethernet suffers from frequent disconnections.
     
    MotoDC likes this.
  5. barad

    barad New Member

    The only workaround I've found so far has been limiting the network speed to 100Mbps - which completely stops the disconnection, but limits me to 10% of my local network speed - which is not an acceptable long-term solution.

    This is most likely a driver issue or a hardware issue with the AX88197, as I'm able to maintain stable 1Gbps connections with other adapters on the same network setup (same cable, router, etc.).

    Screen Shot 2019-08-13 at 16.36.43.png
     
    MotoDC likes this.
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for sharing this with me. Please send me a PM together with a video showing the internet issue while using our Razer Core X Chroma together with its serial number, let's continue from there.
     
    MotoDC likes this.
  7. barad

    barad New Member

    Thank you for the quick reply.

    Am I correct in assuming you requested a video and serial number in order to start an RMA process?

    If so - I can now confirm that this is a driver issue, and doubt an RMA would be necessary or helpful.
    I've loaded windows on my MacBook via bootcamp and tested the Core X Chroma's ethernet adapter extensively. I was unable to reproduce the disconnection on Windows. Note that the laptop, Core X, and all connected network components (cable, router, etc.) remained identical - but MacOs is plagued with disconnections while Windows is stable.

    I've monitored the output of dmesg following a network disconnect (see attached below). If you still require a video, I'd be happy to provide it. Please let me know what additional information you need in order to resolve this driver issue.

    Code:
    AX88179: monitorLinkStatus - Link is down.
    AX88179: monitorLinkStatus - Link down
    AX88179: monitorLinkStatus - Link is up at 1000 Mbps - Full Duplex (PHY regs 5,6:0xc1e1,0x000d)
    AX88179: monitorLinkStatus - Link is down.
    AX88179: monitorLinkStatus - Link down
    syscall_extension_issue failed: 2syscall_extension_issue failed: 1syscall_extension_issue failed: 2syscall_extension_issue failed: 1AX88179: monitorLinkStatus - Link is up at 1000 Mbps - Full Duplex (PHY regs 5,6:0xc1e1,0x000d)
    syscall_extension_issue failed: 2Sandbox: fontd(341) deny(1) file-issue-extension target:/Network/Library class:com.apple.app-sandbox.readsyscall_extension_issue failed: 1AX88179 outputStart - getLength(): 0 TotalBufLen: 3672 pktCount: 8
    
     
    Razer.Speedcr0ss and MotoDC like this.
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for replicating the issue via dual boot on your macOS. That's indeed odd as you're using the same hardware and networking components but has a different result when used on another operating system. And yes, we normally escalate the issue if it needs an intervention from our Senior Support Team aside from processing an RMA since the issue looks like an ethernet module driver compatibility for macOS.
     
    MotoDC likes this.
  9. MotoDC

    MotoDC New Member

    Not too worried about the colours, but would like the built in Ethernet to work. I can confirm it is connected via thunderbolt/usb-c. I have actually tested it with a different. year older MPB 13” with the same issues showing up.

    It seems from other user’s posts that this is a shared issue, and seems to be isolated to a MacOS driver issue based on the boot camp test in this thread.

    I’ll try to set the speed down to 100Mbps for the interim, however I’d really like to see the driver fixed.

    Thanks!
     
    Razer.Speedcr0ss likes this.
  10. MotoDC

    MotoDC New Member

    Thanks for the workaround barad, I’ll give this a shot in the mean time. Also, I’m getting the same error logs in MacOS you are. Wasn’t sure if they were Ethernet related or not, but looks like they are.
     
    barad likes this.
  11. MotoDC

    MotoDC New Member

    Can confirm that @barad 's workaround does indeed seem to work. Hardcoding the NIC speed to 100Mbps earlier today and it seems to have no drops.

    Of course, I'd also like to see this fixed to support the full speed of 1Gbps. Here is the OS link info for reference.

    Code:
    xxxxx:~ user$ ifconfig en8
    en8: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
        ether 90:20:3a:11:XX:YY
        inet6 fe80::1a:0000:0000:1248%en8 prefixlen 64 secured scopeid 0x10
        inet 192.168.1.103 netmask 0xffffff00 broadcast 192.168.1.255
        nd6 options=201<PERFORMNUD,DAD>
        media: 100baseTX <full-duplex,flow-control>
        status: active
     
  12. Experiencing intermittent drops every 5-10 minutes on a Windows 10 machine as well. Have updated all related and unrelated drivers, BIOS, etc. I've tried setting the port to 100mb to no avail and I've also tried other fixes such as turning off USB power management, selective suspend, etc. Contacted Razer support and they suggested I get a replacement.
     
  13. barad

    barad New Member

    I'm guessing you're suffering from an unrelated issue, maybe indeed faulty hardware.

    Im my case the Gigabit ethernet is very stable on Win10, but utterly unusable on MacOs.

    @Razer.Speedcr0ss - any update regarding when your SW team could look into this?
     
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey! I haven't got an update yet but if you can send me a PM and gather details from you to raise this concern, it will be helpful.
     
  15. MotoDC

    MotoDC New Member

    Razer.Speedcr0ss likes this.
  16. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Alrighty! Feel free to update me anytime. :wink_:
     
  17. codylo

    codylo New Member

    Got the same issue with a 2018 Mac Mini and 2017 MacBook Pro 13" baseline model. The Ethernet connection drops a few minutes after boot, and not able to recover unless restart the interface.

    I connect the Core X Chroma (with a RX590) to my Lenovo X1 5th gen and the Ethernet AX88179 work flawlessly under Windows 10.

    I have been contacting Razer support for a few months but this is not yet resolved, I have given up using the Ethernet on the Chroma with macOS, I use the built-in Ethernet on the Mac Mini instead, I believe the issue is on the AX88179 macOS driver instead. Hardware should be fine (with Windows 10).
     
    Razer.Speedcr0ss likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >