Core X - Won't power up

Discussion in 'Systems' started by a209896, May 3, 2019.

Thread Status:
Not open for further replies.
  1. a209896

    a209896 New Member

    There is a thread about this (locked) issue that could probably solve my problem (assuming it is not DOA) but the pictures are missing in the thread and I cannot tell where the sensor is. Does anyone have pics or more detailed instructions of where this sensor is and what may need to be bent a bit?
     
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    It’s Core v1 thread and old thread would be automatically locked. Core X has its own physical power button unlike Core v1 and v2. PSU and rail connection may be also different.
     
  3. a209896

    a209896 New Member

    Ah, darn...I'm at a loss as to the problem then. :frown_: I'd hate to have to return it already.

    *edit* Nevermind.I hooked it up to my iPad that uses USB C and it powered up. Apparently the thunderbolt cable has to be connected to a machine in order for it to power up. I'm waiting for my mac mini to arrive so I didn't have anything to plug it into. That should probably be in the instructions. I would think it could power up prior to connecting a machine.
     
    Last edited by a moderator: May 15, 2019
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    I don’t have Core x but yeah TB3 enclosure without host laptop it won’t power up to detect system...Sidenote You know you need also a GPU right:wink_: beside Mac mini. Interesting though to know it’s powered up by usb c connection device like on your Tablet.
     
  5. a209896

    a209896 New Member

    Yeah, I have a Vega 56 card in there.
    I figured the iPad would do the trick if a connection was needed because the cable can charge a laptop.
     
    Joikansai likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >