Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Crashed during recovery

Discussion in 'Mice and Surfaces' started by 18_GKT, Sep 15, 2020.

  1. 18_GKT

    18_GKT New Member

    my Razer blade 13 crashed while I was doing a Recovery and now it won't reset no matter what I do. I've tried holding the power button for 8-10 seconds but it still doesn't restart. It takes me to a screen of options to continue or troubleshoot or shutdown and I've tried all 3 options and it still doesn't work.
     
  2. LiLmEgZ

    LiLmEgZ Active Member

    Were you trying to do a OS Restore from Factory Image of some sort? Its really just easier to download the latest released Windows 10 image and do a clean install from that instead as Windows 10 pretty much has drivers to get you up n running post install until you update them manually :)
     
    FiszPL likes this.
  3. FiszPL

    FiszPL Well-Known Member

    +1 for clean install.
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    You can also make nios factory reset to default settings if you change any of the settings that can be related to blade hdd settings.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >