Death Adder elite suddenly not recognized by Synapse 2.

Discussion in 'Razer Support' started by thinkBudGreenvine129, Jul 31, 2021.

Thread Status:
Not open for further replies.
  1. I have tried all the recommended procedures on Razer's website. I have uninstalled, and reinstalled just as the webpage says, but it is still not recognized. I has worked fine for a couple of years until just 3 days ago. The only problem I can see is that the Razer Control Device has an yellow exclamation point in Device Manager ( i use Windows 10). I have uninstalled both this and the mouse several times. I have tried uninstalling everything, unplugging the mouse, rebooting and then plugging in. However, If i plug in the mouse before installing Synapse, the yellow exclamation point already shows. I can find no way to update or effect his Razer Control Device. Any suggestions?
     
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Could you send me a short clip or a screenshot of what's happening in your Device Manager so I can grasp the situation? For now, let's try to uninstall your mouse driver by following the steps on this link. Also, please ensure that you have the latest Windows OS. If the problem persists, send me the serial number of your mouse. I can use that to verify its model and look for other possible solutions.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >