Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

deathadder elite buttons not working

Discussion in 'Razer Support' started by SaltySr, Aug 10, 2020.

  1. SaltySr

    SaltySr New Member

    hey i've been using the razerdeath adder elite for 2 years now but all of a sudden the sensitifity button and the side buttons don't work anymore i know it's not the hardware because they still feel the same and still hear the same somethimes they do work but only if i restart my pc but only for like 5 minutes does anyone have the same problem or know a solution
     
  2. This has started to happen to me too! Sometimes they work for a few minutes but thats it, then they stop working again.I tried to clean reinstall synapse 2, but with no success. Then i tried synapse 3, and guess what, it would't even recognize the devices. So now i'm back to synapse 2 and still having the issue. Hope some can help us out!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >