Deathadder Erratic Movements

Discussion in 'Razer Support' started by Mathroy, Mar 22, 2021.

Thread Status:
Not open for further replies.
  1. Mathroy

    Mathroy New Member

    Hey there,

    I've been using my Deathadder for about a year and a half now, and just about 2 days ago it started having erratic movements while playing a game. At first I thought it was buggy Cyberpunk 2077 being buggy, but then I played Fall Guys and noticed the same thing was happening. So while playing, at first, everything is fine, but then usually after 20-25 min of gaming it just starts doing weird movements and not responding to my movement inputs. That usually happens shortly after Shift-tabbing (that's opening the Steam overlay). When that's happening, using the Steam overlay fixes the problem. I can browse the Steam overlay without a problem but upon going back to the game it breaks it again.

    Unplugging the mouse doesn't fix the problem, but restarting the game competely does. But even then, I have to restart the game every 20-30 min or so because the problem keeps coming back.

    I didn't make any changes to my rig or setup and Razer Synapse is up-to-date. I am using X-Mouse Button Control but that's only to disable Mouse Buttons 4 and 5 and nothing else. My mouse seems to be in very good condition so I'm not sure what's causing this. Any input would be appreciated, thanks.

    Oh, and my mouse looks like a Deathadder V2 only the middle buttons used to change the sensitivity are a bit thinner and longer than the one they show on Razer's website.
    https://www.razer.com/ca-en/gaming-mice/Razer-DeathAdder-V2/RZ01-03210100-R3U1

    EDIT1: Going to Device Manager and Mice and other pointing devices it says it's a Razer DeathAdder Elite.
    EDIT2: When ingame, for example Fall Guys, hitting ESC once to go to the settings menu, the cursor does NOT have any erratic movement there. It's only when actually playing.
    EDIT3: I haven't used the Steam ingame Overlay for over an hour just to test this, and I haven't had any trouble. Maybe 5-10 minutes after opening the Overlay, the problem appeared! So as it seems to be a problem with Steam and not the mouse, I'll switch to the Steam Forums and I'll come back here if it ends up being a problem with my mouse.
     
    Last edited: Mar 22, 2021
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >