Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

DEATHADDER V2 issue with on windows start up

Discussion in 'Razer Support' started by LykosRaw, May 17, 2020.

  1. LykosRaw

    LykosRaw New Member

    Hi all, not sure how common this issue is but EVERYTIME I boot up my pc my deathadder V2 has to be unplugged then plugged back in again. when i boot up the lights don't turn on and the mouse does not work at all, it works fine once plugged back in again. I know it's a small issue but it's so frustrating.
    bit of extra info on the issue... I also have a blackwidow keyboard, wolverine controller and nari ultimate headset that work completely fine and don't have this issue. I have the latest version of synapse and I have tried changing to different USB ports.
    any help would be appreciated, thanks.
     
  2. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! Thanks for posting your concern here. Have you tried connecting the mouse to a different computer and see if the issue persists? If yes, please send me a PM together with the mouse serial number. Let's continue from there.
     
  3. 5p0773r

    5p0773r New Member

    Same issue with me
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >