Deathadder V2 pro de-syncs

Discussion in 'Razer Support' started by Joriyn, Nov 6, 2021.

Thread Status:
Not open for further replies.
  1. Joriyn

    Joriyn New Member

    Hi team!

    I've been having this issue for quite some time mostly when I'm gaming. I use the deathadder v2 pro connected wirelessly via the dock and I noticed that from time to time, the mouse "disconnects" or the chroma resets and has to re-sync with the lighting setup of the dock. I'm not sure if its an issue caused by the mouse, the dock or synapse, tho. I've made sure everything is updated with the latest version but it keeps happening and I cant seem to find any action that specifically triggers this issue.

    It's getting pretty annoying since I get this random disconnects multiple times, in some games happens really often and its ruining the user experience for me.

    I'm willing to provide any info needed in order to fix this issue

    Kind regards!
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Verify if the behavior happens while the Razer Synapse 3.0 is closed or disabled. Also, ensure that your devices are connected directly to your computer's USB port. If this is a desktop PC, connect the peripherals at the rear USB port or plug it into a different PC and see if it helps. I’ll be locking this thread now. Feel free to send me a PM anytime or visit our self-help options should you have other questions or concerns.
     
    Joriyn likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >