Devices not Showing in Synapse

Discussion in 'Razer Support' started by rigidavocado23, Dec 1, 2020.

Thread Status:
Not open for further replies.
  1. rigidavocado23

    rigidavocado23 New Member

    So I have been troubleshooting an issue where the battery percentage of my Basilisk Ultimate wasn't correct in the Synapse program. I could leave it plugged in or charging on the dock and come back a few hours later and the mouse says 2%. Plug it in with a cable and use it for an hour or two and it then say 1%. I ultimately uninstalled synapse and deleted all files locally per the guide before reinstalling. After the reinstall, the percentage is correct and is charging. However, now my Blackwidow Elite keyboard doesn't show up in the synapse software. This is really frustrating.

    Should I do another complete reinstall? I've done the obvious troubleshooting of unplugging it and plugging it back in, restarted, all windows updates are completed. I have also removed the drivers for the keyboard with devices.msc and then done a search for new devices.

    Any suggestions would be appreciated.

    Hardware:
    Basilisk Ultimate with dock
    Blackwidow Elite
     
  2. rigidavocado23

    rigidavocado23 New Member

    Update: I plugged the cable into the dock to use the mouse wirelessly, now the only thing that shows in Synapse is the Dock. My mouse and keyboard don't show. Do I need to do yet another complete reinstall?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >