Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Diablo 3 paid to play

Discussion in 'Razer Cortex' started by Behemoth12324, May 4, 2017.

Thread Status:
Not open for further replies.
  1. Behemoth12324

    Behemoth12324 New Member

    Hello!
    I see u guys added diablo 3 support for your paid to play feature but im still not able to earn zsilver when i play diablo so do i need to update cortex or something cause its not working?
     
    Last edited: May 4, 2017
    zender likes this.
  2. SirJayDee

    SirJayDee Active Member

    I have the same problem, I got in touch with the support and troubleshooting has started. When in Diablo 3's dashboard, to you see a widget called Achievements?
     
  3. watchingskies

    watchingskies New Member

    I am having the same issue. I don't have an achievements widget for Diablo 3 in the dashboard, but when I go to the Overwatch one there is an achievements widget. Just tried reinstalling the Cortex app and still have the same issue.
     
  4. PigeTheGreat

    PigeTheGreat Member

    I'd give it a few days for them to announce that they've put more games on paid to play. Could be that we're just spotting the changes as they're doing them, and they're not fully implemented yet!
    Always a good idea to check the game dashboard for the achievement widget first before trying to dive in to it for zSilver.

    That being said, GTA V has the widget for it, and that was added the same time as Diablo 3.
     
  5. SirJayDee

    SirJayDee Active Member

    Update: I was asked to re-install Cortex which didn't help and I've now sent a couple of logs to the dev team.
     
  6. Behemoth12324

    Behemoth12324 New Member

    I also tried to re-install and it didnt work. I guess they need a few days or something is bugged.
     
  7. G3rme

    G3rme New Member

    Same problem here.. played approximately 2 hours and no zsilver. I've re-installed Cortex, but the problem is still there. No achievement section either...
     
  8. Coffindodger

    Coffindodger New Member

    Yea getting the same issue here as well hope they fix this soon.
     
  9. RedxSnake

    RedxSnake New Member

    I have the same problem
     
  10. Skrunch

    Skrunch Active Member

    Also having the same issue, I even checked under "view supported games" on the Cortex app and Diablo III is already listed but it's not working.
     
  11. Jakel309_no_id

    Jakel309_no_id New Member

    Same issue. I play a lot too, so it would be nice if this was working.
     
  12. G3rme

    G3rme New Member

    I sent a feedback to the support team. They told me that they "are in the midst of fixing this bug". So hopefully this issue will be gone soon.
     
  13. WraithGore

    WraithGore New Member

    Not trying to steal the thread but sounds like what i experienced in another game (Neverwinter) with first sign in after installing Cortex. Played 2 hours never saw a change, not even when reset came. So I'll log a support ticket. Just passing on it's not just Diablo 3 being affected (From what I am seeing). And I did try Diablo 3 as well, with no success as you all have demonstrated.
     
  14. petersutton1

    petersutton1 New Member

    When attempting to launch D3:ROS 64bit version through cortex, (which only shows D3 text logo and artwork possibly not registering the expansion?) It merely opens the battle-net launcher with the error window "The folder doesn't contain the correct version of this game please check the installation path and try again". Both my laucher files and coretx point to the same "Diablo III64.exe" file. Is this the same thing people are experiencing?
    only things I can think of is its blizzards launcher being super aggressive in blocking.. the fact that there's multiple exe files for each install or that somehow its not picking up the current version/update as blizzard games update a lot with seasons patches ect..
     
  15. G3rme

    G3rme New Member

    Well.. in my case there are no error windows, but yes Cortex only opens the Bnet launcher, and the image of the game in the library is the logo of Diablo 3, not Reaper of Souls..
    In addition to that, Cortex also tells me that there is RoS available for the game (which I already have installed). It seems like Cortex doesn't recognize what version of the game I have.
     
    Last edited: May 8, 2017
    TheBentrick likes this.
  16. Behemoth12324

    Behemoth12324 New Member

    Ye now i can see achievements tab for d3 but i cant earn zsilver.And just like this guy said it seems he only recognizes diablo 3 and not the ros expansion cause i have an icon tellin me to upgrade.
     
  17. Jakel309_no_id

    Jakel309_no_id New Member

    I just got through earning zSilver from playing it and I have RoS.
     
  18. Behemoth12324

    Behemoth12324 New Member

    how did u do something or?
    edit: i just got zsilver too but there is no notification when u launch the game so i thought i wont get any.
     
  19. Jakel309_no_id

    Jakel309_no_id New Member

    I didn't get a notification either. I just looked at Cortex and saw that I got zSilver today from playing games and the only thing I played today was Diablo 3.
     
  20. SirJayDee

    SirJayDee Active Member

    I too get zsilver now, but as many others I get no notification about it apart from the achievements widget in Cortex. I Also noticed that the FPS-chart is empty. Do you guys/gals have any FPS-graph in Cortex for Diablo 3?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >